SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Forum/Board/Portal)  >   Joomla! Vendors:   joomla.org
Joomla! Input Validation Flaws Let Remote Users Inject SQL Commands and Conduct Cross-Site Scripting Attacks
SecurityTracker Alert ID:  1040316
SecurityTracker URL:  http://securitytracker.com/id/1040316
CVE Reference:   CVE-2018-6376, CVE-2018-6377, CVE-2018-6379, CVE-2018-6380   (Links to External Site)
Date:  Feb 1 2018
Impact:   Disclosure of authentication information, Disclosure of system information, Disclosure of user information, Execution of arbitrary code via network, Modification of user information, User access via network
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): 1.5.0 - 3.8.3
Description:   Several vulnerabilities were reported in Joomla!. A remote user can inject SQL commands. A remote user can conduct cross-site scripting attacks.

The software does not properly validate user-supplied input in the Hathor postinstall message. A remote user can supply a specially crafted parameter value to execute SQL commands on the underlying database [CVE-2018-6376]. Versions 3.7.0 and later are affected.

The software does not properly filter HTML code from user-supplied input before displaying the input. A remote user can cause arbitrary scripting code to be executed by the target user's browser. The code will originate from the site running the Joomla! software and will run in the security context of that site. As a result, the code will be able to access the target user's cookies (including authentication cookies), if any, associated with the site, access data recently submitted by the target user via web form to the site, or take actions on the site acting as the target user.

The Uri class (formerly JUri) is affected [CVE-2018-6379].

The 'com_fields' parameter is affected in several field types [CVE-2018-6377]. Versions 3.7.0 and later are affected.

The module chromes are affected [CVE-2018-6380]. Versions 3.0.0 and later are affected.

Karim Ouerghemmi, ripstech.com, Octavian Cinciu, Benjamin Trenkle, JSST, and David Jardin, JSST, reported these vulnerabilities.

Impact:   A remote user can execute SQL commands on the underlying database.

A remote user can access the target user's cookies (including authentication cookies), if any, associated with the site running the Joomla! software, access data recently submitted by the target user via web form to the site, or take actions on the site acting as the target user.

Solution:   The vendor has issued a fix (3.8.4).

The vendor advisory is available at:

https://developer.joomla.org/security-centre.html

Vendor URL:  developer.joomla.org/security-centre/722-20180104-core-sqli-vulnerability.html (Links to External Site)
Cause:   Input validation error
Underlying OS:  Linux (Any), UNIX (Any), Windows (Any)

Message History:   None.


 Source Message Contents



[Original Message Not Available for Viewing]


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2019, SecurityGlobal.net LLC