SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Web Server/CGI)  >   Apache Tomcat Vendors:   Apache Software Foundation
(Ubuntu Issues Fix) Apache Tomcat Application Listener Facade Object Error Lets Remote Users Modify Data on the Target System
SecurityTracker Alert ID:  1040118
SecurityTracker URL:  http://securitytracker.com/id/1040118
CVE Reference:   CVE-2017-5648   (Links to External Site)
Date:  Jan 8 2018
Impact:   Disclosure of system information, Disclosure of user information, Modification of system information, Modification of user information
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): 7.0.0 to 7.0.75, 8.0.0.RC1 to 8.0.41, 8.5.0 to 8.5.11, 9.0.0.M1 to 9.0.0.M17
Description:   A vulnerability was reported in Apache Tomcat. A remote user can access and modify data on the target system.

Some application listener calls do not use the appropriate facade object. An untrusted application running under a SecurityManager can retain a reference to the call or response object and access or modify data associated with a different application.

Impact:   A remote user can access and modify data on the target system.
Solution:   Ubuntu has issued a fix.

The Ubuntu advisory is available at:

https://www.ubuntu.com/usn/usn-3519-1

Vendor URL:  www.ubuntu.com/usn/usn-3519-1 (Links to External Site)
Cause:   Access control error
Underlying OS:  Linux (Ubuntu)
Underlying OS Comments:  14.04 LTS, 16.04 LTS, 17.04

Message History:   This archive entry is a follow-up to the message listed below.
Apr 11 2017 Apache Tomcat Application Listener Facade Object Error Lets Remote Users Modify Data on the Target System



 Source Message Contents



[Original Message Not Available for Viewing]


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2021, SecurityGlobal.net LLC