SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Generic)  >   Apache Struts Vendors:   Apache Software Foundation
Apache Struts REST Plugin JSON Library Bug Lets Remote Users Deny Service
SecurityTracker Alert ID:  1039946
SecurityTracker URL:  http://securitytracker.com/id/1039946
CVE Reference:   CVE-2017-15707   (Links to External Site)
Date:  Dec 1 2017
Impact:   Denial of service via network
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): 2.5 - 2.5.14
Description:   A vulnerability was reported in Apache Struts. A remote user can cause denial of service conditions on the target system.

A remote user can send specially crafted JSON data to trigger a flaw in the REST Plugin's default JSON-lib handler and cause denial of service conditions.

Huijun Chen, XiaoLong Zhu - Huawei Technologies reported this vulnerability.

Impact:   A remote user can cause denial of service conditions.
Solution:   The vendor has issued a fix (2.5.14.1).

The vendor advisory is available at:

https://cwiki.apache.org/confluence/display/WW/S2-054

Vendor URL:  cwiki.apache.org/confluence/display/WW/S2-054 (Links to External Site)
Cause:   Not specified
Underlying OS:  Linux (Any), UNIX (Any), Windows (Any)

Message History:   This archive entry has one or more follow-up message(s) listed below.
Mar 5 2018 (IBM Issues Fix for IBM InfoSphere Metadata Workbench) Apache Struts REST Plugin JSON Library Bug Lets Remote Users Deny Service
IBM has issued a fix for IBM InfoSphere Metadata Workbench.



 Source Message Contents

Subject:  https://cwiki.apache.org/confluence/display/WW/S2-054

 
 


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2019, SecurityGlobal.net LLC