SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (E-mail Client)  >   Mozilla Thunderbird Vendors:   Mozilla.org
(Ubuntu Issues Fix for Mozilla Thunderbird) Mozilla Firefox Multiple Bugs Let Remote Users Spoof URLs, Conduct Cross-Site Scripting Attacks, Bypass Security Controls, Obtain Potentially Sensitive Information, and Execute Arbitrary Code and Let Local Users Gain Elevated Privileges
SecurityTracker Alert ID:  1039945
SecurityTracker URL:  http://securitytracker.com/id/1039945
CVE Reference:   CVE-2017-7826, CVE-2017-7828, CVE-2017-7830   (Links to External Site)
Date:  Dec 1 2017
Impact:   Disclosure of system information, Disclosure of user information, Execution of arbitrary code via network, Modification of system information, Modification of user information, User access via local system, User access via network
Fix Available:  Yes  Vendor Confirmed:  Yes  

Description:   Multiple vulnerabilities were reported in Mozilla Firefox. A remote user can cause arbitrary code to be executed on the target user's system. A remote user can modify data on the target system. A remote user can bypass security controls on the target system. A remote user can obtain potentially sensitive information on the target system. A remote user can spoof URLs. A local user can obtain elevated privileges on the target system. Mozilla Thunderbird is affected.

A remote user can trigger a same-origin policy bypass in the Resource Timing API to view potentially sensitive URLs on the target user's system [CVE-2017-7830].

A remote user can access ostensibly restricted properties via the exposedProps mechanism on proxy objects [CVE-2017-7831].

A remote user can spoof domains via the dotless 'i' characters followed by any of various unicode accents [CVE-2017-7832].

A remote user can spoof domains via Arabic and Indic vowel marker characters combined with Latin characters [CVE-2017-7833].

A remote user can exploit a flaw in the decoding of labels in international domain names to potentially spoof domains [CVE-2017-7838].

A remote user can open 'data:' URLs in new tabs to bypass Content Security Policy and potentially conduct cross-site scripting attacks [CVE-2017-7834].

A remote user can exploit a content blocking flaw to redirect the target user's browser to another site [CVE-2017-7835].

A remote user can use meta tags via SVG loaded as 'img' tags to set cookies for the target page [CVE-2017-7837].

A remote user can use control characters before 'javascript:' URLs to bypass cross-site scripting protections [CVE-2017-7839].

A remote user can cause javascript to be injected into exported bookmarks [CVE-2017-7840].

A remote user can supply specially crafted requests to bypass Referrer Policy for 'link' elements [CVE-2017-7842].

A remote user can create specially crafted content that, when loaded by the target user, will execute arbitrary code on the target user's system.

A use-after-free memory error may occur in PressShell [CVE-2017-7828].

Other memory corruption errors may occur [CVE-2017-7826, CVE-2017-7827].

A local user can invoke Pingsender via the Firefox Health Report to run libcurl with the privileges of the browser and gain elevated privileges on the target system [CVE-2017-7836]. macOS and Linux-based systems are affected.

Andre Bargull, Ben Kelly, Bob Clary, Boris Zbarsky, Byron Campen, Carsten Book, Christian Holler, Corey Bonnell, David Keeler, Eric Lawrence, Ezra Caltum, Gary Kwong, Hanno Bock, Jan de Mooij, Jason Kratzer, Jesse Schwartzentruber, Jet Villegas, Jon Coppeard, Jonathan Kew, Jordi Chancel, Julien Cristau, Jun Kokatsu, Marcia Knous, Nicholas Nethercote, Nils, Oriol Brufau, Philipp, Randell Jesup, Rayyan Bijoora, Ryan VanderMeulen, Ting-Yu Chou, and Tyson Smith reported these vulnerabilities.

Impact:   A remote user can create content that, when loaded by the target user, will execute arbitrary code on the target user's system.

A remote user can modify data on the target system.

A local user can obtain elevated privileges on the target system.

A remote user can bypass security controls on the target system.

A remote user can obtain potentially sensitive information on the target system.

A remote user can spoof a URL.

Solution:   Ubuntu has issued a fix for CVE-2017-7826, CVE-2017-7828, and CVE-2017-7830 for Mozilla Thunderbird.

The Ubuntu advisory is available at:

https://www.ubuntu.com/usn/usn-3490-1

Vendor URL:  www.ubuntu.com/usn/usn-3490-1 (Links to External Site)
Cause:   Access control error, Input validation error
Underlying OS:  Linux (Ubuntu)
Underlying OS Comments:  14.04 LTS, 16.04 LTS, 17.04, 17.10

Message History:   This archive entry is a follow-up to the message listed below.
Nov 15 2017 Mozilla Firefox Multiple Bugs Let Remote Users Spoof URLs, Conduct Cross-Site Scripting Attacks, Bypass Security Controls, Obtain Potentially Sensitive Information, and Execute Arbitrary Code and Let Local Users Gain Elevated Privileges



 Source Message Contents



[Original Message Not Available for Viewing]


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2019, SecurityGlobal.net LLC