SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Generic)  >   curl Vendors:   curl.haxx.se
(Oracle Issues Fix for Oracle Linux) cURL Buffer Overread in Processing IMAP FETCH Response Data Lets Remote Users Deny Service or Obtain Potentially Sensitive Information
SecurityTracker Alert ID:  1039882
SecurityTracker URL:  http://securitytracker.com/id/1039882
CVE Reference:   CVE-2017-1000257   (Links to External Site)
Date:  Nov 29 2017
Impact:   Denial of service via network, Disclosure of system information, Disclosure of user information
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): 7.20.0 - 7.56.0
Description:   A vulnerability was reported in cURL. A remote user can cause the target application to crash. A remote user can obtain potentially sensitive information on the target system.

A remote user can return a specially crafted IMAP FETCH response to trigger a buffer overread in the IMAP handler and obtain potentially sensitive information from memory on the target system or cause the target application using libcurl to crash.

Brian Carpenter, Geeknik Labs, and 0xd34db347 reported this vulnerability.

Impact:   A remote user can cause the target application using libcurl to crash.

A remote user can obtain potentially sensitive information on the target system.

Solution:   Oracle has issued a fix.

The Oracle Linux advisory is available at:

http://linux.oracle.com/errata/ELSA-2017-3263.html

Vendor URL:  linux.oracle.com/errata/ELSA-2017-3263.html (Links to External Site)
Cause:   Boundary error
Underlying OS:  Linux (Oracle)
Underlying OS Comments:  7

Message History:   This archive entry is a follow-up to the message listed below.
Oct 24 2017 cURL Buffer Overread in Processing IMAP FETCH Response Data Lets Remote Users Deny Service or Obtain Potentially Sensitive Information



 Source Message Contents

Subject:  [El-errata] ELSA-2017-3263 Moderate: Oracle Linux 7 curl security update

Oracle Linux Security Advisory ELSA-2017-3263

http://linux.oracle.com/errata/ELSA-2017-3263.html

The following updated rpms for Oracle Linux 7 have been uploaded to the 
Unbreakable Linux Network:

x86_64:
curl-7.29.0-42.el7_4.1.x86_64.rpm
libcurl-7.29.0-42.el7_4.1.i686.rpm
libcurl-7.29.0-42.el7_4.1.x86_64.rpm
libcurl-devel-7.29.0-42.el7_4.1.i686.rpm
libcurl-devel-7.29.0-42.el7_4.1.x86_64.rpm


SRPMS:
http://oss.oracle.com/ol7/SRPMS-updates/curl-7.29.0-42.el7_4.1.src.rpm



Description of changes:

[7.29.0-42.el7_4.1]
- fix buffer overflow while processing IMAP FETCH response 
(CVE-2017-1000257)


_______________________________________________
El-errata mailing list
El-errata@oss.oracle.com
https://oss.oracle.com/mailman/listinfo/el-errata
 
 


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2019, SecurityGlobal.net LLC