SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Generic)  >   Shibboleth Service Provider Vendors:   Shibboleth
Shibboleth Service Provider Error in Dynamic MetadataProvider Plugin Lets Remote Users Bypass Security Restrictions on the Target System
SecurityTracker Alert ID:  1039808
SecurityTracker URL:  http://securitytracker.com/id/1039808
CVE Reference:   GENERIC-MAP-NOMATCH   (Links to External Site)
Date:  Nov 15 2017
Impact:   Host/resource access via network
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): prior to 2.6.1
Description:   A vulnerability was reported in Shibboleth Service Provider. A remote user can bypass security controls on the target system.

The 'Dynamic' MetadataProvider plugin does not properly configure filters and fails to apply security checks. As a result, a remote user can bypass signature verification, enforcement of validity periods, and other deployment-specific security controls.

Impact:   A remote user can bypass security controls on the target system, including signature verification, enforcement of validity periods, and other deployment-specific security controls.
Solution:   The vendor has issued a fix (2.6.1).

The vendor advisory is available at:

https://shibboleth.net/community/advisories/secadv_20171115.txt

Vendor URL:  shibboleth.net/community/advisories/secadv_20171115.txt (Links to External Site)
Cause:   Configuration error, State error

Message History:   None.


 Source Message Contents

Subject:  https://shibboleth.net/community/advisories/secadv_20171115.txt

 
 


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2021, SecurityGlobal.net LLC