SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Generic)  >   Apache OpenOffice Vendors:   Apache Software Foundation, OpenOffice.org
Apache OpenOffice Impress Out-of-Bounds Memory Write Error in PPTStyleSheet Lets Remote Users Execute Arbitrary Code
SecurityTracker Alert ID:  1039734
SecurityTracker URL:  http://securitytracker.com/id/1039734
CVE Reference:   CVE-2017-12607   (Links to External Site)
Date:  Nov 3 2017
Impact:   Execution of arbitrary code via network, User access via network
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): 4.1.3 and prior
Description:   A vulnerability was reported in Apache OpenOffice Impress. A remote user can cause arbitrary code to be executed on the target user's system.

A remote user can create a specially crafted document file that, when loaded by the target user, will trigger an out-of-bounds memory write error in PPTStyleSheet and execute arbitrary code on the target system. The code will run with the privileges of the target user.

Marcin 'Icewall' Noga of Cisco Talos reported this vulnerability.

Impact:   A remote user can create content that, when loaded by the target user, will execute arbitrary code on the target user's system.
Solution:   The vendor has issued a fix (4.1.4).

The vendor advisory is available at:

https://www.openoffice.org/security/cves/CVE-2017-12607.html

Vendor URL:  www.openoffice.org/security/cves/CVE-2017-12607.html (Links to External Site)
Cause:   Boundary error
Underlying OS:  Linux (Any), UNIX (Any), Windows (Any)

Message History:   None.


 Source Message Contents

Subject:  https://www.openoffice.org/security/cves/CVE-2017-12607.html

 
 


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2019, SecurityGlobal.net LLC