SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Generic)  >   wget Vendors:   GNU [multiple authors]
(CentOS Issues Fix) wget Buffer Overflows in Processing HTTP Data Lets Remote Users Execute Arbitrary Code
SecurityTracker Alert ID:  1039682
SecurityTracker URL:  http://securitytracker.com/id/1039682
CVE Reference:   CVE-2017-13089, CVE-2017-13090   (Links to External Site)
Date:  Oct 27 2017
Impact:   Execution of arbitrary code via network, User access via network
Fix Available:  Yes  Vendor Confirmed:  Yes  

Description:   Two vulnerabilities were reported in wget. A remote user can execute arbitrary code on the target system.

A remote server can return send specially crafted HTTP data to the connected target client user to trigger a buffer overflow and execute arbitrary code on the target client system.

A heap overflow in processing HTTP chunk size values may occur in the fd_read_body() function in 'src/retr.c' [CVE-2017-13090].

A heap overflow in processing HTTP chunk size values may occur in the skip_short_body() function in 'src/http.c' [CVE-2017-13089].

The original advisory is available at:

https://www.viestintavirasto.fi/en/cybersecurity/vulnerabilities/2017/haavoittuvuus-2017-037.html

Antti Levomaki, Christian Jalio, Joonas Pihlaja from Forcepoint and Juhani Eronen from Finnish National Cyber Security Centre reported these vulnerabilities.

Impact:   A remote server can execute arbitrary code on the target connect client system.
Solution:   CentOS has issued a fix.

x86_64:
d74e0e13c9f03a464eb508b06ff96dd93a58297e0515f1a29015fec5334f1b80 wget-1.14-15.el7_4.1.x86_64.rpm

Source:
0dec11e33a32973c79bcd6a690907a2f8e99507d1ff3f38be7f5f34996f5fe87 wget-1.14-15.el7_4.1.src.rpm

Cause:   Boundary error
Underlying OS:  Linux (CentOS)
Underlying OS Comments:  7

Message History:   This archive entry is a follow-up to the message listed below.
Oct 26 2017 wget Buffer Overflows in Processing HTTP Data Lets Remote Users Execute Arbitrary Code



 Source Message Contents

Subject:  [CentOS-announce] CESA-2017:3075 Important CentOS 7 wget Security Update


CentOS Errata and Security Advisory 2017:3075 Important

Upstream details at : https://access.redhat.com/errata/RHSA-2017:3075

The following updated files have been uploaded and are currently 
syncing to the mirrors: ( sha256sum Filename ) 

x86_64:
d74e0e13c9f03a464eb508b06ff96dd93a58297e0515f1a29015fec5334f1b80  wget-1.14-15.el7_4.1.x86_64.rpm

Source:
0dec11e33a32973c79bcd6a690907a2f8e99507d1ff3f38be7f5f34996f5fe87  wget-1.14-15.el7_4.1.src.rpm



-- 
Johnny Hughes
CentOS Project { http://www.centos.org/ }
irc: hughesjr, #centos@irc.freenode.net
Twitter: @JohnnyCentOS

_______________________________________________
CentOS-announce mailing list
CentOS-announce@centos.org
https://lists.centos.org/mailman/listinfo/centos-announce
 
 


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2020, SecurityGlobal.net LLC