SecurityTracker.com
Keep Track of the Latest Vulnerabilities
with SecurityTracker!
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 
Sign Up
Sign Up for Your FREE Weekly SecurityTracker E-mail Alert Summary
Instant Alerts
Buy our Premium Vulnerability Notification Service to receive customized, instant alerts
Affiliates
Put SecurityTracker Vulnerability Alerts on Your Web Site -- It's Free!
Partners
Become a Partner and License Our Database or Notification Service





Category:   Application (Generic)  >   Aruba Mobility Controller Vendors:   Aruba Networks
Aruba Mobility Controller Multiple Bugs Let Remote Users Access Files and Execute Arbitrary Code and Let Remote Authenticated Users Inject SQL Commands
SecurityTracker Alert ID:  1039580
SecurityTracker URL:  http://securitytracker.com/id/1039580
CVE Reference:   CVE-2017-9000, CVE-2017-9003   (Links to External Site)
Date:  Oct 16 2017
Impact:   Disclosure of system information, Disclosure of user information, Execution of arbitrary code via network, User access via network
Fix Available:  Yes  Vendor Confirmed:  Yes  

Description:   Several vulnerabilities were reported in Aruba Mobility Controller. A remote authenticated user can inject SQL commands. A remote user can execute arbitrary code on the target system. A remote user can obtain files on the target system.

A remote user can send a specially crafted request to TCP port 8080 or 8081 to view arbitrary files on the target system [CVE-2017-9000].

A remote user can send specially crafted data to trigger a memory corruption error and execute arbitrary code on the target system [CVE-2017-9003].

The software does not properly validate user-supplied input. A remote authenticated administrative user can supply a specially crafted parameter value to execute SQL commands on the underlying database and read or write arbitrary data.

@mongobug (via BugCrowd) reported these vulnerabilities.

Impact:   A remote authenticated user can execute SQL commands on the underlying database.

A remote user can execute arbitrary code on the target system.

A remote user can obtain arbitrary files on the target system.

Solution:   The vendor has issued a fix (6.3.1.25, 6.4.4.16, 6.5.1.9, 6.5.3.3, 6.5.4.2, 8.1.0.4).

The vendor advisory is available at:

http://www.arubanetworks.com/assets/alert/ARUBA-PSA-2017-006.txt

Vendor URL:  www.arubanetworks.com/assets/alert/ARUBA-PSA-2017-006.txt (Links to External Site)
Cause:   Access control error, Input validation error

Message History:   None.


 Source Message Contents

Subject:  http://www.arubanetworks.com/assets/alert/ARUBA-PSA-2017-006.txt

 
 


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2018, SecurityGlobal.net LLC