SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Generic)  >   curl Vendors:   curl.haxx.se
(Ubuntu Issues Fix) libcurl FTP PWD Response Processing Buffer Overread Lets Remote Users Deny Service
SecurityTracker Alert ID:  1039547
SecurityTracker URL:  http://securitytracker.com/id/1039547
CVE Reference:   CVE-2017-1000254   (Links to External Site)
Date:  Oct 11 2017
Impact:   Denial of service via network
Fix Available:  Yes  Vendor Confirmed:  Yes  Exploit Included:  Yes  
Version(s): 7.7 - 7.55.1
Description:   A vulnerability was reported in libcurl. A remote user can cause denial of service conditions on the target system.

A remote server can return a specially crafted response to a PWD command issued by the target connected client library to trigger a parsing error and buffer overread and cause libcurl to crash.

Max Dymond reported this vulnerability.

Impact:   A remote server can cause the target connected client library to crash.
Solution:   Ubuntu has issued a fix.

The Ubuntu advisory is available at:

https://www.ubuntu.com/usn/usn-3441-1

Vendor URL:  www.ubuntu.com/usn/usn-3441-1 (Links to External Site)
Cause:   Boundary error
Underlying OS:  Linux (Ubuntu)
Underlying OS Comments:  14.04 LTS, 16.04 LTS, 17.04

Message History:   This archive entry is a follow-up to the message listed below.
Oct 5 2017 libcurl FTP PWD Response Processing Buffer Overread Lets Remote Users Deny Service



 Source Message Contents



[Original Message Not Available for Viewing]


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2019, SecurityGlobal.net LLC