SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Security)  >   RSA Archer eGRC Vendors:   EMC, RSA
RSA Archer eGRC Multiple Bugs Let Remote Users Upload Files and Conduct Cross-Site Scripting Attacks and Let Remote Authenticated Users Gain Elevated Privileges
SecurityTracker Alert ID:  1039518
SecurityTracker URL:  http://securitytracker.com/id/1039518
CVE Reference:   CVE-2017-14369, CVE-2017-14370, CVE-2017-14371, CVE-2017-14372, CVE-2017-8016, CVE-2017-8025   (Links to External Site)
Date:  Oct 6 2017
Impact:   Disclosure of authentication information, Disclosure of user information, Execution of arbitrary code via network, Modification of user information, User access via network
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): prior to 6.2.0.5
Description:   Multiple vulnerabilities were reported in RSA Archer eGRC. A remote user can upload files to the target system. A remote authenticated user can gain elevated privileges. A remote user can conduct cross-site scripting attacks.

The software does not properly filter HTML code from user-supplied input before displaying the input. A remote or remote authenticated user can cause arbitrary scripting code to be executed by the target user's browser. The code will originate from the site running the RSA Archer eGRC software and will run in the security context of that site. As a result, the code will be able to access the target user's cookies (including authentication cookies), if any, associated with the site, access data recently submitted by the target user via web form to the site, or take actions on the site acting as the target user.

The Questionnaire ID field is affected [CVE-2017-8016].

The Source Asset ID field is affected [CVE-2017-14370].

The request URL parameter is affected [CVE-2017-14371].

Certain RSA Archer Help pages are affected [CVE-2017-14372].

A remote user can upload files to arbitrary paths on the target system [CVE-2017-8025].

A remote authenticated user can gain elevated privileges on the target system [CVE-2017-14369]. This can be exploited to export certain application records.

Erlend Leiknes, Security Consultant with Mnemonic AS, and Mohit Rawat reported these vulnerabilities.

Impact:   A remote user can upload files to the target system.

A remote authenticated user can gain elevated privileges on the target system.

A remote or remote authenticated user can access the target user's cookies (including authentication cookies), if any, associated with the site running the RSA Archer eGRC software, access data recently submitted by the target user via web form to the site, or take actions on the site acting as the target user.

Solution:   The vendor has issued a fix (6.2 Patch 6; Advisory ESA-2017-111).
Vendor URL:  www.emc.com/ (Links to External Site)
Cause:   Access control error, Input validation error

Message History:   None.


 Source Message Contents



[Original Message Not Available for Viewing]


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2019, SecurityGlobal.net LLC