SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   OS (UNIX)  >   Apple macOS/OS X Vendors:   Apple
(Apple Issues Fix for Apple macOS Server) FreeRADIUS Overflows and Memory Leaks Let Remote Users Deny Service and Execute Arbitrary Code
SecurityTracker Alert ID:  1039429
SecurityTracker URL:  http://securitytracker.com/id/1039429
CVE Reference:   CVE-2017-10978, CVE-2017-10979   (Links to External Site)
Date:  Sep 26 2017
Impact:   Denial of service via network, Execution of arbitrary code via network, User access via network
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): macOS Server prior to 5.4
Description:   Multiple vulnerabilities were reported in FreeRADIUS. A remote user can cause denial of service conditions on the target system. A remote user can execute arbitrary code on the target system. Apple macOS Server is affected.

A remote user can send specially crafted RADIUS data to trigger an overflow in make_secret() and cause the target service to crash [CVE-2017-10978].

A remote user can send specially crafted RADIUS data to trigger an overflow in rad_coalesce() and execute arbitrary code on the target system [CVE-2017-10979]. The code will run with the privileges of the target service. Versions 2.0.0 through 2.2.9 are affected.

A remote user can send specially crafted DHCP data to trigger a memory leak in decode_tlv() and consume excessive memory on the target system [CVE-2017-10980]. Versions 2.0.0 through 2.2.9 are affected.

A remote user can send specially crafted DHCP data to trigger a memory leak in fr_dhcp_decode() and consume excessive memory on the target system [CVE-2017-10981]. Versions 2.0.0 through 2.2.9 are affected.

A remote user can send specially crafted DHCP data to trigger a read overflow in fr_dhcp_decode_options() and cause the target service to crash [CVE-2017-10982]. Versions 2.0.0 through 2.2.9 are affected.

A remote user can send specially crafted DHCP option 63 data to trigger a read overflow in fr_dhcp_decode_options() and cause the target service to crash [CVE-2017-10983].

Guido Vranken reported these vulnerabilities.

Impact:   A remote user can cause denial of service conditions.

A remote user can execute arbitrary code on the target system.

Solution:   The Apple has issued a fix for CVE-2017-10978 and CVE-2017-10979 for macOS Server (5.4).

The Apple advisory is available at:

https://support.apple.com/en-us/HT208102

Vendor URL:  support.apple.com/en-us/HT208102 (Links to External Site)
Cause:   Access control error, Boundary error

Message History:   This archive entry is a follow-up to the message listed below.
Jul 18 2017 FreeRADIUS Overflows and Memory Leaks Let Remote Users Deny Service and Execute Arbitrary Code



 Source Message Contents



[Original Message Not Available for Viewing]


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2019, SecurityGlobal.net LLC