SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Generic)  >   Apple Xcode Vendors:   Apple
(Apple Issues Fix for Apple Xcode) Git 'ssh://' URL Processing Flaw Lets Remote Users Execute Arbitrary Commands on the Target System
SecurityTracker Alert ID:  1039390
SecurityTracker URL:  http://securitytracker.com/id/1039390
CVE Reference:   CVE-2017-1000117   (Links to External Site)
Date:  Sep 20 2017
Impact:   Execution of arbitrary code via network, User access via network
Fix Available:  Yes  Vendor Confirmed:  Yes  

Description:   A vulnerability was reported in Git. A remote user can execute arbitrary code on the target system. Apple Xcode is affected.

A remote user (e.g., repository) can return a specially crafted 'ssh://' URL to execute arbitrary shell commands on the target user' system. The code will run with the privileges of the target user.

The vulnerability can be triggered during 'clone' commands.

The original advisory is available at:

http://blog.recurity-labs.com/2017-08-10/scm-vulns

Joern Schneeweisz of Recurity Labs reported this vulnerability.

Impact:   A remote user can execute arbitrary shell commands on the target system.
Solution:   The Apple has issued a fix for Apple Xcode (9.0).

The Apple advisory is available at:

https://support.apple.com/en-us/HT208103

Vendor URL:  support.apple.com/en-us/HT208103 (Links to External Site)
Cause:   Input validation error
Underlying OS:  UNIX (macOS/OS X)

Message History:   This archive entry is a follow-up to the message listed below.
Aug 11 2017 Git 'ssh://' URL Processing Flaw Lets Remote Users Execute Arbitrary Commands on the Target System



 Source Message Contents



[Original Message Not Available for Viewing]


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2019, SecurityGlobal.net LLC