SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Security)  >   FreeRADIUS Vendors:   FreeRADIUS Server Project
(Oracle Issues Fix for Oracle Linux) FreeRADIUS Overflows and Memory Leaks Let Remote Users Deny Service and Execute Arbitrary Code
SecurityTracker Alert ID:  1038965
SecurityTracker URL:  http://securitytracker.com/id/1038965
CVE Reference:   CVE-2017-10978, CVE-2017-10979, CVE-2017-10980, CVE-2017-10981, CVE-2017-10982, CVE-2017-10983   (Links to External Site)
Date:  Jul 20 2017
Impact:   Denial of service via network, Execution of arbitrary code via network, User access via network
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): 2.0.0 through 3.0.14
Description:   Multiple vulnerabilities were reported in FreeRADIUS. A remote user can cause denial of service conditions on the target system. A remote user can execute arbitrary code on the target system.

A remote user can send specially crafted RADIUS data to trigger an overflow in make_secret() and cause the target service to crash [CVE-2017-10978].

A remote user can send specially crafted RADIUS data to trigger an overflow in rad_coalesce() and execute arbitrary code on the target system [CVE-2017-10979]. The code will run with the privileges of the target service. Versions 2.0.0 through 2.2.9 are affected.

A remote user can send specially crafted DHCP data to trigger a memory leak in decode_tlv() and consume excessive memory on the target system [CVE-2017-10980]. Versions 2.0.0 through 2.2.9 are affected.

A remote user can send specially crafted DHCP data to trigger a memory leak in fr_dhcp_decode() and consume excessive memory on the target system [CVE-2017-10981]. Versions 2.0.0 through 2.2.9 are affected.

A remote user can send specially crafted DHCP data to trigger a read overflow in fr_dhcp_decode_options() and cause the target service to crash [CVE-2017-10982]. Versions 2.0.0 through 2.2.9 are affected.

A remote user can send specially crafted DHCP option 63 data to trigger a read overflow in fr_dhcp_decode_options() and cause the target service to crash [CVE-2017-10983].

Guido Vranken reported these vulnerabilities.

Impact:   A remote user can cause denial of service conditions.

A remote user can execute arbitrary code on the target system.

Solution:   Oracle has issued a fix.

The Oracle Linux advisory is available at:

http://linux.oracle.com/errata/ELSA-2017-1759.html

Vendor URL:  linux.oracle.com/errata/ELSA-2017-1759.html (Links to External Site)
Cause:   Access control error, Boundary error
Underlying OS:  Linux (Oracle)
Underlying OS Comments:  6

Message History:   This archive entry is a follow-up to the message listed below.
Jul 18 2017 FreeRADIUS Overflows and Memory Leaks Let Remote Users Deny Service and Execute Arbitrary Code



 Source Message Contents

Subject:  [El-errata] ELSA-2017-1759 Important: Oracle Linux 6 freeradius security update

Oracle Linux Security Advisory ELSA-2017-1759

http://linux.oracle.com/errata/ELSA-2017-1759.html

The following updated rpms for Oracle Linux 6 have been uploaded to the 
Unbreakable Linux Network:

i386:
freeradius-2.2.6-7.el6_9.i686.rpm
freeradius-krb5-2.2.6-7.el6_9.i686.rpm
freeradius-ldap-2.2.6-7.el6_9.i686.rpm
freeradius-mysql-2.2.6-7.el6_9.i686.rpm
freeradius-perl-2.2.6-7.el6_9.i686.rpm
freeradius-postgresql-2.2.6-7.el6_9.i686.rpm
freeradius-python-2.2.6-7.el6_9.i686.rpm
freeradius-unixODBC-2.2.6-7.el6_9.i686.rpm
freeradius-utils-2.2.6-7.el6_9.i686.rpm

x86_64:
freeradius-2.2.6-7.el6_9.x86_64.rpm
freeradius-krb5-2.2.6-7.el6_9.x86_64.rpm
freeradius-ldap-2.2.6-7.el6_9.x86_64.rpm
freeradius-mysql-2.2.6-7.el6_9.x86_64.rpm
freeradius-perl-2.2.6-7.el6_9.x86_64.rpm
freeradius-postgresql-2.2.6-7.el6_9.x86_64.rpm
freeradius-python-2.2.6-7.el6_9.x86_64.rpm
freeradius-unixODBC-2.2.6-7.el6_9.x86_64.rpm
freeradius-utils-2.2.6-7.el6_9.x86_64.rpm


SRPMS:
http://oss.oracle.com/ol6/SRPMS-updates/freeradius-2.2.6-7.el6_9.src.rpm



Description of changes:

[2.2.6-7]
- Resolves: Bug#1469115 CVE-2017-10979 freeradius: Out-of-bounds write in
                         rad_coalesce()
- Resolves: Bug#1469118 CVE-2017-10978 freeradius: Out-of-bounds read/write
                         due to improper output buffer size check in 
make_secret()
- Resolves: Bug#1469120 CVE-2017-10980 freeradius: Memory leak in 
decode_tlv()
- Resolves: Bug#1469122 CVE-2017-10981 freeradius: Memory leak in
                         fr_dhcp_decode()
- Resolves: Bug#1469124 CVE-2017-10982 freeradius: Out-of-bounds read in
                         fr_dhcp_decode_options()
- Resolves: Bug#1469126 CVE-2017-10983 freeradius: Out-of-bounds read in
                         fr_dhcp_decode() when decoding option 63


_______________________________________________
El-errata mailing list
El-errata@oss.oracle.com
https://oss.oracle.com/mailman/listinfo/el-errata
 
 


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2019, SecurityGlobal.net LLC