SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Generic)  >   Adobe Captivate Vendors:   Adobe Systems Incorporated
Adobe Captivate Input Validation Flaw in Internal Server Reporting Functions Lets Remote Users Obtain Potentially Sensitive Information and Execute Arbitrary Code on the Target System
SecurityTracker Alert ID:  1038657
SecurityTracker URL:  http://securitytracker.com/id/1038657
CVE Reference:   CVE-2017-3087, CVE-2017-3098   (Links to External Site)
Updated:  Jun 20 2017
Original Entry Date:  Jun 13 2017
Impact:   Disclosure of system information, Disclosure of user information, Execution of arbitrary code via network, Modification of system information, Modification of user information
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): 8, 9, 10
Description:   A vulnerability was reported in Adobe Captivate. A remote user can execute arbitrary code on the target system. A remote user can obtain potentially sensitive information on the target system.

A remote user can send a specially crafted request to trigger an input validation flaw in some internal server reporting scripts ('internalserverread.php' and 'internalServerReporting.php') and view potentially sensitive information on the target system [CVE-2017-3087].

A remote user can trigger an input validation flaw in the quiz reporting feature to read and write arbitrary files on the target system [CVE-2017-3098]. This can be exploited to execute arbitrary code on the target system.

Tomas Rzepka reported one vulnerability.

Impact:   A remote user can obtain potentially sensitive information on the target system.

A remote user can modify files to execute arbitrary code on the target system.

Solution:   The vendor has issued a fix (hotfix for version 8 and 9; 2017 10.0.0.192).

The vendor advisory is available at:

https://helpx.adobe.com/security/products/captivate/apsb17-19.html

Vendor URL:  helpx.adobe.com/security/products/captivate/apsb17-19.html (Links to External Site)
Cause:   Input validation error
Underlying OS:  UNIX (macOS/OS X), Windows (Any)

Message History:   None.


 Source Message Contents



[Original Message Not Available for Viewing]


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2019, SecurityGlobal.net LLC