SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (File Transfer/Sharing)  >   Samba Vendors:   Samba.org
(Oracle Issues Fix for Oracle Linux) Samba smbd Named Pipe Validation Flaw Lets Remote Authenticated Users Execute Arbitrary Code on the Target System
SecurityTracker Alert ID:  1038587
SecurityTracker URL:  http://securitytracker.com/id/1038587
CVE Reference:   CVE-2017-7494   (Links to External Site)
Date:  May 31 2017
Impact:   Execution of arbitrary code via network, Root access via network
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): 3.5.0 and after
Description:   A vulnerability was reported in Samba. A remote authenticated user can execute arbitrary code on the target system.

A remote authenticated user can upload a shared library to a writable share and then open a specially named pipe endpoint (containing a '/' character) cause the target system to execute the library with root privileges.

steelo reported this vulnerability.

Impact:   A remote authenticated user with write privileges on the target share can execute arbitrary code with root privileges on the target system.
Solution:   Oracle has issued a fix for samba3x.

The Oracle Linux advisory is available at:

http://linux.oracle.com/errata/ELSA-2017-1272.html

Vendor URL:  linux.oracle.com/errata/ELSA-2017-1272.html (Links to External Site)
Cause:   Input validation error
Underlying OS:  Linux (Oracle)
Underlying OS Comments:  5

Message History:   This archive entry is a follow-up to the message listed below.
May 24 2017 Samba smbd Named Pipe Validation Flaw Lets Remote Authenticated Users Execute Arbitrary Code on the Target System



 Source Message Contents

Subject:  [El-errata] ELSA-2017-1272 Important: Oracle Linux 5 samba3x security update

Oracle Linux Security Advisory ELSA-2017-1272

http://linux.oracle.com/errata/ELSA-2017-1272.html

The following updated rpms for Oracle Linux 5 have been uploaded to the 
Unbreakable Linux Network:

i386:
samba3x-3.6.23-13.0.2.el5_11.i386.rpm
samba3x-client-3.6.23-13.0.2.el5_11.i386.rpm
samba3x-common-3.6.23-13.0.2.el5_11.i386.rpm
samba3x-doc-3.6.23-13.0.2.el5_11.i386.rpm
samba3x-domainjoin-gui-3.6.23-13.0.2.el5_11.i386.rpm
samba3x-swat-3.6.23-13.0.2.el5_11.i386.rpm
samba3x-winbind-3.6.23-13.0.2.el5_11.i386.rpm
samba3x-winbind-devel-3.6.23-13.0.2.el5_11.i386.rpm

x86_64:
samba3x-3.6.23-13.0.2.el5_11.x86_64.rpm
samba3x-client-3.6.23-13.0.2.el5_11.x86_64.rpm
samba3x-common-3.6.23-13.0.2.el5_11.x86_64.rpm
samba3x-doc-3.6.23-13.0.2.el5_11.x86_64.rpm
samba3x-domainjoin-gui-3.6.23-13.0.2.el5_11.x86_64.rpm
samba3x-swat-3.6.23-13.0.2.el5_11.x86_64.rpm
samba3x-winbind-3.6.23-13.0.2.el5_11.i386.rpm
samba3x-winbind-3.6.23-13.0.2.el5_11.x86_64.rpm
samba3x-winbind-devel-3.6.23-13.0.2.el5_11.i386.rpm
samba3x-winbind-devel-3.6.23-13.0.2.el5_11.x86_64.rpm

ia64:
samba3x-3.6.23-13.0.2.el5_11.ia64.rpm
samba3x-client-3.6.23-13.0.2.el5_11.ia64.rpm
samba3x-common-3.6.23-13.0.2.el5_11.ia64.rpm
samba3x-doc-3.6.23-13.0.2.el5_11.ia64.rpm
samba3x-domainjoin-gui-3.6.23-13.0.2.el5_11.ia64.rpm
samba3x-swat-3.6.23-13.0.2.el5_11.ia64.rpm
samba3x-winbind-3.6.23-13.0.2.el5_11.ia64.rpm
samba3x-winbind-devel-3.6.23-13.0.2.el5_11.ia64.rpm

SRPMS:
http://oss.oracle.com/ol5/SRPMS-updates/samba3x-3.6.23-13.0.2.el5_11.src.rpm



Description of changes:

[3.6.23-13.0.2]
- Fix CVE-2017-7494

_______________________________________________
El-errata mailing list
El-errata@oss.oracle.com
https://oss.oracle.com/mailman/listinfo/el-errata
 
 


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2021, SecurityGlobal.net LLC