SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (VPN)  >   OpenVPN Vendors:   openvpn.net
OpenVPN Access Server Input Validation Flaw Lets Remote Users Conduct Session Fixation Attacks to Hijack a Target User's Session
SecurityTracker Alert ID:  1038547
SecurityTracker URL:  http://securitytracker.com/id/1038547
CVE Reference:   CVE-2017-5868   (Links to External Site)
Date:  May 24 2017
Impact:   Modification of authentication information, Modification of system information, User access via network
Vendor Confirmed:  Yes  Exploit Included:  Yes  
Version(s): 2.1.4
Description:   A vulnerability was reported in OpenVPN Access Server. A remote user can conduct session fixation attacks to hijack a target user's session.

A remote user can create a specially crafted URL containing the '%0A' character that, when loaded by the target user prior to authentication, will inject headers and set the session cookie to a specified value. After the target user authenticates to the target OpenVPN Access Server, the remote user can hijack the target user's session.

The vendor was notified on February 6, 2017.

Julien Boulet of Sysdream reported this vulnerability.

Impact:   A remote user can hijack a target user's session.
Solution:   No solution was available at the time of this entry.
Vendor URL:  openvpn.net/index.php/access-server/overview.html (Links to External Site)
Cause:   Input validation error
Underlying OS:  Linux (Any), UNIX (Any)

Message History:   None.


 Source Message Contents



[Original Message Not Available for Viewing]


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2021, SecurityGlobal.net LLC