SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Generic)  >   Foxit Reader Vendors:   Foxit Software
Foxit Reader Multiple Flaws Let Remote Users Execute Arbitrary Code and Obtain Potentially Sensitive Information
SecurityTracker Alert ID:  1037619
SecurityTracker URL:  http://securitytracker.com/id/1037619
CVE Reference:   GENERIC-MAP-NOMATCH   (Links to External Site)
Date:  Jan 18 2017
Impact:   Disclosure of system information, Disclosure of user information, Execution of arbitrary code via network, User access via network
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): 8.1.4.1208 and prior
Description:   Several vulnerabilities were reported in Foxit Reader. A remote user can cause arbitrary code to be executed on the target user's system. A remote user can obtain potentially sensitive information on the target system.

A remote user can create a specially crafted file that, when loaded by the target user, will obtain potentially sensitive information or execute arbitrary code on the target system.

An out-of-bounds memory error may occur in parsing JPEG2000 images. Windows systems are affected.

A use-after-free memory error may occur. Windows systems are affected.

An out-of-bounds memory read error may occur in parsing fonts. Windows systems are affected.

An out-of-bounds memory read or memory corruption error may occur when converting JPEG or TIFF files to PDFs. Windows systems are affected.

A stack overflow may occur. Linux systems are affected.

kdot (via Trend Micro's Zero Day Initiative), Steven Seeley of Source Incite (via Trend Micro's Zero Day Initiative), Gogil of STEALIEN (via Trend Micro's Zero Day Initiative), Ke Liu of Tencent's Xuanwu LAB (via Trend Micro's Zero Day Initiative), Juan Pablo Lopez Yacubian (via Trend Micro's Zero Day Initiative), and Dmitri Kaslov reported these vulnerabilities.

Impact:   A remote user can create content that, when loaded by the target user, will execute arbitrary code on the target user's system.

A remote user can obtain potentially sensitive information on the target system.

Solution:   The vendor has issued a fix (Foxit Reader for Windows 8.2; Foxit Reader for Linux 2.3).

The vendor advisory is available at:

https://www.foxitsoftware.com/support/security-bulletins.php#content-2017

Vendor URL:  www.foxitsoftware.com/support/security-bulletins.php#content-2017 (Links to External Site)
Cause:   Access control error, Boundary error
Underlying OS:  Linux (Any), Windows (Any)

Message History:   None.


 Source Message Contents



[Original Message Not Available for Viewing]


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2019, SecurityGlobal.net LLC