SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Web Server/CGI)  >   IBM WebSphere MQ Vendors:   IBM
IBM WebSphere MQ JMSObjectMessage Class Object Deserialization Flaw Lets Remote Users Execute Arbitrary Code on the Target System
SecurityTracker Alert ID:  1037561
SecurityTracker URL:  http://securitytracker.com/id/1037561
CVE Reference:   CVE-2016-0360   (Links to External Site)
Date:  Jan 7 2017
Impact:   Execution of arbitrary code via network, User access via network
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): 7.0.1, 7.1, 7.5, 8.0, 9.0
Description:   A vulnerability was reported in IBM WebSphere MQ. A remote user can execute arbitrary code on the target system.

A remote user can send specially crafted data to trigger an object deserialization flaw in the JMSObjectMessage class to execute arbitrary Java code on the target system. The code will run with the privileges of the target Java Message Service.

Impact:   A remote user can execute arbitrary code on the target system.
Solution:   IBM has issued a fix (APAR IT14385).

The IBM advisory is available at:

http://www-01.ibm.com/support/docview.wss?uid=swg21983457

Vendor URL:  www-01.ibm.com/support/docview.wss?uid=swg21983457 (Links to External Site)
Cause:   Access control error
Underlying OS:  Linux (Any), UNIX (AIX), UNIX (HP/UX), UNIX (Solaris - SunOS), Windows (Any)

Message History:   None.


 Source Message Contents



[Original Message Not Available for Viewing]


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2020, SecurityGlobal.net LLC