SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (E-mail Client)  >   Mozilla Thunderbird Vendors:   Mozilla.org
(Ubuntu Issues Fix for Mozilla Thunderbird) Mozilla Firefox Multiple Flaws Let Remote Users Execute Arbitrary Code, Bypass Security Restrictions, Determine File Paths, and Obtain Potentially Sensitive Information
SecurityTracker Alert ID:  1037140
SecurityTracker URL:  http://securitytracker.com/id/1037140
CVE Reference:   CVE-2016-5257, CVE-2016-5270, CVE-2016-5272, CVE-2016-5274, CVE-2016-5276, CVE-2016-5277, CVE-2016-5278, CVE-2016-5280, CVE-2016-5281, CVE-2016-5284   (Links to External Site)
Date:  Oct 28 2016
Impact:   Denial of service via network, Disclosure of system information, Disclosure of user information, Execution of arbitrary code via network, User access via network
Fix Available:  Yes  Vendor Confirmed:  Yes  

Description:   Multiple vulnerabilities were reported in Mozilla Firefox. A remote user can cause arbitrary code to be executed on the target user's system. A remote user can cause the target application to crash. A remote user can obtain potentially sensitive information on the target system. Mozilla Thunderbird is affected.

A remote user can create specially crafted content that, when loaded by the target user, will execute arbitrary code on the target user's system.

A heap overflow may occur in nsCaseTransformTextRunFactory::TransformString() [CVE-2016-5270].

An invalid cast may occur in nsImageGeometryMixin() [CVE-2016-5272].

A use-after-free memory error may occur in mozilla::a11y::DocAccessible::ProcessInvalidationList() [CVE-2016-5276].

A use-after-free memory error may occur in nsFrameManager::CaptureFrameState() [CVE-2016-5274].

A use-after-free memory error may occur in nsRefreshDriver::Tick() [CVE-2016-5277].

A buffer overflow may occur in mozilla::gfx::FilterSupport::ComputeSourceNeededRegions() [CVE-2016-5275].

A buffer overflow may occur in nsBMPEncoder::AddImageFrame() [CVE-2016-5278].

A use-after-free memory error may occur in mozilla::nsTextNodeDirectionalityMap::RemoveElementFromMap() [CVE-2016-5280].

A use-after-free memory error may occur in DOMSVGLength() [CVE-2016-5281].

Various other errors may occur [CVE-2016-5256, CVE-2016-5257].

A remote user can cause the target user's application to crash.

An out-of-bounds memory read error may occur in mozilla::net::IsValidReferrerPolicy() [CVE-2016-2827].

An error may occur in mozilla::a11y::HyperTextAccessible::GetChildOffset() [CVE-2016-5273].

A remote user can view potentially sensitive information on the target system.

An out-of-bounds read error may occur in PropertyProvider::GetSpacingInternal() [CVE-2016-5271].

A full path disclosure may occur after a drag and drop operation [CVE-2016-5279].

A favicon can be loaded via non-whiletlisted protocols [CVE-2016-5282].

A cross-origin 'iframe src' tag fragment timing attack may disclose data [CVE-2016-5283].

Certificate pinning for add-on updates is not effective [CVE-2016-5284]. A remote user with an incorrectly issued certificate for a Mozilla web site can send arbitrary add-on updates to the target user. Users that have installed add-ons are affected.

Atte Kettunen, Abhishek Arya, Nils, Rafael Gieschke, Mei Wang, Brian Carpenter, Richard Newman, Gavin Sharp, Ryan Duff, Christoph Diehl, Christian Holler, Gary Kwong, Nathan Froyd, Honza Bambas, Seth Fowler, Michael Smith, Andrew McCreight, Dan Minor, Byron Campen, Jon Coppeard, Steve Fink, Tyson Smith, Philipp, and Carsten Book reported these vulnerabilities.

Impact:   A remote user can create content that, when loaded by the target user, will execute arbitrary code on the target user's system.

A remote user can cause the target application to crash.

A remote user can obtain potentially sensitive information on the target system.

Solution:   Ubuntu has issued a fix for CVE-2016-5257, CVE-2016-5270, CVE-2016-5272, CVE-2016-5274, CVE-2016-5276, CVE-2016-5277, CVE-2016-5278, CVE-2016-5280, CVE-2016-5281, and CVE-2016-5284 for Mozilla Thunderbird.

The Ubuntu advisory is available at:

http://www.ubuntu.com/usn/usn-3112-1

Vendor URL:  www.ubuntu.com/usn/usn-3112-1 (Links to External Site)
Cause:   Access control error, Boundary error
Underlying OS:  Linux (Ubuntu)
Underlying OS Comments:  12.04 LTS, 14.04 LTS, 16.04 LTS, 16.10

Message History:   This archive entry is a follow-up to the message listed below.
Sep 21 2016 Mozilla Firefox Multiple Flaws Let Remote Users Execute Arbitrary Code, Bypass Security Restrictions, Determine File Paths, and Obtain Potentially Sensitive Information



 Source Message Contents



[Original Message Not Available for Viewing]


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2021, SecurityGlobal.net LLC