SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Generic)  >   PHP Vendors:   PHP Group
PHP Multiple Memory Corruption Errors Let Remote and Local Users Execute Arbitrary Code on the Target System
SecurityTracker Alert ID:  1036836
SecurityTracker URL:  http://securitytracker.com/id/1036836
CVE Reference:   CVE-2016-7411, CVE-2016-7412, CVE-2016-7413, CVE-2016-7414, CVE-2016-7416, CVE-2016-7417, CVE-2016-7418   (Links to External Site)
Date:  Sep 16 2016
Impact:   Execution of arbitrary code via local system, Execution of arbitrary code via network, User access via local system, User access via network
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): prior to versions 5.6.26, 7.0.11
Description:   Multiple vulnerabilities were reported in PHP. A remote or local user can execute arbitrary code on the target system.

The specific impact depends on the application using PHP.

A null pointer dereference may occur in zval_delref_p().

A null pointer dereference may occur in imap_mail().

A memory corruption error may occur in processing locale data [CVE-2016-7416].

A heap overflow may occur in the processing of BIT fields in mysqlnd [CVE-2016-7412].

An out-of-bounds memory error may occur in phar_parse_zipfile() [CVE-2016-7414].

An out-of-bounds memory error may occur in phar_parse_tarfile().

A memory corruption error may occur when unserializing SplArray [CVE-2016-7417].

A null pointer dereference may occur in shm_attach().

A use-after-free memory error may occur in wddx_deserialize() [CVE-2016-7413].

An out-of-bounds memory read error may occur in php_wddx_push_element() [CVE-2016-7418].

A memory corruption error may occur during deserialized object destruction [CVE-2016-7411]. Version 5.6.x is affected.

Impact:   A remote or local user can execute arbitrary code on the target system.
Solution:   The vendor has issued a fix (5.6.26, 7.0.11).

The vendor advisories are available at:

http://php.net/ChangeLog-5.php#5.6.26
http://php.net/ChangeLog-7.php#7.0.11

Vendor URL:  php.net/ChangeLog-7.php#7.0.11 (Links to External Site)
Cause:   Access control error, Boundary error
Underlying OS:  Linux (Any), UNIX (Any), Windows (Any)

Message History:   This archive entry has one or more follow-up message(s) listed below.
Oct 5 2016 (Ubuntu Issues Fix) PHP Multiple Memory Corruption Errors Let Remote and Local Users Execute Arbitrary Code on the Target System
Ubuntu has issued a fix for Ubuntu Linux 12.04 LTS, 14.04 LTS, and 16.04 LTS.
Dec 13 2016 (Apple Issues Fix for Apple macOS/OS X) PHP Multiple Memory Corruption Errors Let Remote and Local Users Execute Arbitrary Code on the Target System
Apple has issued a fix for Apple macOS/OS X.



 Source Message Contents



[Original Message Not Available for Viewing]


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2019, SecurityGlobal.net LLC