SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (E-mail Client)  >   Mozilla Thunderbird Vendors:   Mozilla.org
(Oracle Issues Fix for Oracle Linux for Mozilla Thunderbird) Mozilla Firefox Multiple Flaws Let Remote Users Execute Arbitrary Code, Bypass Security Restrictions, Spoof Content, Modify Files, and Obtain Potentially Sensitive Information
SecurityTracker Alert ID:  1036731
SecurityTracker URL:  http://securitytracker.com/id/1036731
CVE Reference:   CVE-2016-2836   (Links to External Site)
Date:  Sep 6 2016
Impact:   Disclosure of system information, Disclosure of user information, Execution of arbitrary code via local system, Execution of arbitrary code via network, Modification of system information, Modification of user information, User access via local system, User access via network
Fix Available:  Yes  Vendor Confirmed:  Yes  

Description:   Multiple vulnerabilities were reported in Mozilla Firefox. A remote user can cause arbitrary code to be executed on the target user's system. A remote user can modify files on the target system. A remote user can bypass security controls on the target system. A remote user can obtain potentially sensitive information on the target system. A remote user can spoof content. A local user can gain elevated privileges on the target system. Mozilla Thunderbird is affected.

A remote user can create specially crafted content that, when loaded by the target user, will execute arbitrary code on the target user's system.

Various memory corruption errors may occur [CVE-2016-2835, CVE-2016-2836].

A heap overflow may occur in nsBidi::BracketData::AddOpening() [CVE-2016-2838].

A stack underflow may occur in mozilla::gfx::BasePoint4d() in the processing of clipping regions in 2D graphics [CVE-2016-5252].

A type confusion error may occur in nsDisplayList::HitTest() [CVE-2016-5263].

A heap overflow may occur in the ClearKey Content Decryption Module (CDM) [CVE-2016-2837].

An integer overflow may occur in WebSocketChannel [CVE-2016-5261].

A use-after-free memory error may occur in nsNodeUtils::NativeAnonymousChildListChange() in the processing of SVG elements [CVE-2016-5264].

A use-after-free memory error may occur in CanonicalizeXPCOMParticipant() [CVE-2016-5259].

A use-after-free memory error may occur in WebRTC [CVE-2016-5258].

A use-after-free memory error may occur in nsXULPopupManager::KeyDown() [CVE-2016-5254].

A use-after-free memory error may occur in js::PreliminaryObjectArray::sweep() [CVE-2016-5255].

A remote user can cause scripting code to execute inside a sandboxed IFRAME that does not permit scripts [CVE-2016-5262].

A remote server can keep a connection open to a target user that has previously requested the favicon after the target user has closed the page to track the target user's IP address as it subsequently changes [CVE-2016-2830].

A remote user can cause the Cairo graphics layer on Linux-based systems (via LibAV) to crash [CVE-2016-2839].

A remote user can use non-ASCII and emjoi characters in 'data:' URLs to spoof URLs in the location bar [CVE-2016-5251].

In certain cases, a local user can exploit a flaw in the Updater on Windows-based systems to potentially gain elevated privileges [CVE-2016-5253].

In certain cases, Firefox session restore data may contain plain text passwords [CVE-2016-5260].

A user can create a specially crafted HTML file and shortcut that, when saved to the same directory on the target user's system and then loaded by the target user, will bypass same origin policy and access potentially sensitive information on the target user's system [CVE-2016-5265].

A remote user can exploit a filtering flaw in the processing of URIs that are dragged by the target user from a web page rendered in Firefox to external software (e.g., local file manager) to modify files on the target user's system [CVE-2016-5266].

A remote user can spoof the addressbar in Firefox for Android via right-to-left character sets combined with left-to-right characters [CVE-2016-5267].

A remote user can pass text as parameters to certain 'about:' URLs to spoof browser content [CVE-2016-5268].

A remote user can trigger a flaw in the Resource Timing API to access certain URLs from the previous page [CVE-2016-5250].

Christian Holler, Tyson Smith, Boris Zbarsky, Byron Campen, Julian Seward, Carsten Book, Gary Kwong, Jesse Ruderman, Andrew McCreight, Phil Ringnalda, Philipp, Toni Huttunen, Atte Kettunen, Bert Massop, Firas Salem, Georg Koppen of the Tor Project, Nils, Samuel Gross,
an anonymous security researcher (via Trend Micro's Zero Day Initiative), Rafay Baloch, Holger Fuhrmannek, Abhishek Arya (Inferno) of the Google Chrome Security Team, Jukka Jylanki, Rafael Gieschke, Looben Yang, Abdulrahman Alqabandi, Mike Kaply, Nikita Arykov, musicDespiteEverything,
and Catalin Dumitru from Amazon reported these vulnerabilities.

Impact:   A remote user can create content that, when loaded by the target user, will execute arbitrary code on the target user's system.

A remote user can modify files on the target system.

A remote user can bypass security controls on the target system.

A remote user can obtain potentially sensitive information on the target system.

A remote user can spoof content.

A local user can gain elevated privileges on the target system.

Solution:   Oracle has issued a fix for CVE-2016-2836 for Mozilla Thunderbird.

The Oracle Linux advisory is available at:

http://linux.oracle.com/errata/ELSA-2016-1809.html

Vendor URL:  linux.oracle.com/errata/ELSA-2016-1809.html (Links to External Site)
Cause:   Access control error, Boundary error, Input validation error
Underlying OS:  Linux (Oracle)
Underlying OS Comments:  6, 7

Message History:   This archive entry is a follow-up to the message listed below.
Aug 3 2016 Mozilla Firefox Multiple Flaws Let Remote Users Execute Arbitrary Code, Bypass Security Restrictions, Spoof Content, Modify Files, and Obtain Potentially Sensitive Information



 Source Message Contents

Subject:  [El-errata] ELSA-2016-1809 Important: Oracle Linux 6 thunderbird security update

Oracle Linux Security Advisory ELSA-2016-1809

http://linux.oracle.com/errata/ELSA-2016-1809.html

The following updated rpms for Oracle Linux 6 have been uploaded to the 
Unbreakable Linux Network:

i386:
thunderbird-45.3.0-1.0.1.el6_8.i686.rpm

x86_64:
thunderbird-45.3.0-1.0.1.el6_8.x86_64.rpm


SRPMS:
http://oss.oracle.com/ol6/SRPMS-updates/thunderbird-45.3.0-1.0.1.el6_8.src.rpm



Description of changes:

[45.3.0-1.0.1]
- Replaced thunderbird-redhat-default-prefs.js with 
thunderbird-oracle-default-prefs.js

[45.3.0-1]
- Update to 45.3.0


_______________________________________________
El-errata mailing list
El-errata@oss.oracle.com
https://oss.oracle.com/mailman/listinfo/el-errata
 
 


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2019, SecurityGlobal.net LLC