SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   OS (Other)  >   Apple iOS Vendors:   Apple
Apple iOS WebKit Flaws Let Remote Users Execute Arbitrary Code and Applications Obtain Kernel Memory Contents and Gain Elevated Privileges
SecurityTracker Alert ID:  1036694
SecurityTracker URL:  http://securitytracker.com/id/1036694
CVE Reference:   CVE-2016-4655, CVE-2016-4656, CVE-2016-4657   (Links to External Site)
Date:  Aug 25 2016
Impact:   Disclosure of system information, Execution of arbitrary code via network, Root access via local system, User access via network
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): prior to 9.3.5
Description:   Several vulnerabilities were reported in Apple iOS. A remote user can cause arbitrary code to be executed on the target user's system. A local user can obtain elevated privileges on the target system.

A remote user can create specially crafted web content that, when loaded by the target user, will trigger a memory corruption error in WebKit execute arbitrary code on the target user's system [CVE-2016-4657].

An application can trigger an input validation flaw to obtain portions of kernel memory [CVE-2016-4655].

An application can trigger a memory corruption error in WebKit to execute arbitrary code with kernel privileges [CVE-2016-4656].

Citizen Lab and Lookout reported these vulnerabilities.

Impact:   A remote user can create content that, when loaded by the target user, will execute arbitrary code on the target user's system.

An application can obtain portions of kernel memory contents.

An application can obtain elevated privileges on the target system.

Solution:   The vendor has issued a fix (9.3.5).

The vendor advisory is available at:

https://support.apple.com/en-us/HT207107

Vendor URL:  support.apple.com/en-us/HT207107 (Links to External Site)
Cause:   Access control error, Input validation error

Message History:   This archive entry has one or more follow-up message(s) listed below.
Sep 2 2016 (Apple Issues Fix for Apple macOS/OS X) Apple iOS WebKit Flaws Let Remote Users Execute Arbitrary Code and Applications Obtain Kernel Memory Contents and Gain Elevated Privileges
Apple has issued a fix for Apple macOS/OS X.



 Source Message Contents



[Original Message Not Available for Viewing]


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2019, SecurityGlobal.net LLC