SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Database)  >   MySQL Vendors:   MySQL.com, Oracle
MySQL Multiple Bugs Let Remote Users Access Data, Remote Authenticated Users Modify Data, Local or Remote Authenticated Users Deny Service, and Local Users Gain Elevated Privileges
SecurityTracker Alert ID:  1036362
SecurityTracker URL:  http://securitytracker.com/id/1036362
CVE Reference:   CVE-2016-3424, CVE-2016-3440, CVE-2016-3452, CVE-2016-3459, CVE-2016-3471, CVE-2016-3477, CVE-2016-3486, CVE-2016-3501, CVE-2016-3518, CVE-2016-3521, CVE-2016-3588, CVE-2016-3614, CVE-2016-3615, CVE-2016-5436, CVE-2016-5437, CVE-2016-5439, CVE-2016-5440, CVE-2016-5441, CVE-2016-5442, CVE-2016-5443, CVE-2016-5444   (Links to External Site)
Date:  Jul 19 2016
Impact:   Denial of service via local system, Denial of service via network, Disclosure of system information, Disclosure of user information, Modification of system information, Modification of user information, User access via local system
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): 5.5.49 and prior, 5.6.30 and prior, 5.7.12 and prior
Description:   Multiple vulnerabilities were reported in MySQL. A remote user can access data on the target system. A remote authenticated user can modify data on the target system. A local or remote authenticated user can cause denial of service conditions on the target system. A local user can obtain elevated privileges on the target system.

A local user can exploit a flaw in the Server: Parser component to gain elevated privileges [CVE-2016-3477].

A remote authenticated user can exploit a flaw in the Server: Optimizer component to cause denial of service conditions [CVE-2016-3440].

A local user can exploit a flaw in the Server: Option component to gain elevated privileges [CVE-2016-3471].

A remote authenticated user can exploit a flaw in the Server: FTS component to cause denial of service conditions [CVE-2016-3486].

A remote authenticated user can exploit a flaw in the Server: Optimizer component to cause denial of service conditions [CVE-2016-3501, CVE-2016-3518].

A remote authenticated user can exploit a flaw in the Server: Types component to cause denial of service conditions [CVE-2016-3521].

A remote authenticated user can exploit a flaw in the Server: InnoDB component to partially modify data and cause denial of service conditions [CVE-2016-3588].

A remote authenticated user can exploit a flaw in the Server: DML component to cause denial of service conditions [CVE-2016-3615].

A remote authenticated user can exploit a flaw in the Server: Security: Encryption component to cause denial of service conditions [CVE-2016-3614].

A remote authenticated user can exploit a flaw in the Server: InnoDB component to cause denial of service conditions [CVE-2016-3459, CVE-2016-5436].

A remote authenticated user can exploit a flaw in the Server: Log component to cause denial of service conditions [CVE-2016-5437].

A remote authenticated user can exploit a flaw in the Server: Optimizer component to cause denial of service conditions [CVE-2016-3424].

A remote authenticated user can exploit a flaw in the Server: Privileges component to cause denial of service conditions [CVE-2016-5439].

A remote authenticated user can exploit a flaw in the Server: RBR component to cause denial of service conditions [CVE-2016-5440].

A remote authenticated user can exploit a flaw in the Server: Replication component to cause denial of service conditions [CVE-2016-5441].

A remote authenticated user can exploit a flaw in the Server: Security: Encryption component to cause denial of service conditions [CVE-2016-5442].

A local user can exploit a flaw in the Server: Connection component to cause denial of service conditions [CVE-2016-5443].

A remote user can exploit a flaw in the Server: Connection component to partially access data [CVE-2016-5444].

A remote user can exploit a flaw in the Server: Security: Encryption component to partially access data [CVE-2016-3452].

The following researchers reported these and other Oracle product vulnerabilities:

Accenture TVM Prague; Adam Willard of Raytheon Foreground Security; Alexander Kornbrust of Red Database Security; Alexander Mirosh of Hewlett Packard Enterprise; Alvaro Munoz of Hewlett Packard Enterprise; Alvaro Munoz of Trend Micro's Zero Day Initiative; Ben Lincoln of NCC Group; Brian Martin of Tenable Network Security; Bruno Cirone; Christian Schneider; David Litchfield of Google;
Devin Rosenbauer of Identity Works LLC; Aleksandar Nikolic of Cisco Talos; Jack Fei of FINRA; Juan Manuel Fernandez Torres of Telefonica.com; Kasper Andersen; Matias Mevied of Onapsis; Matthias Kaiser of Code White; Matthias-Christian Ott; Nicholas Lemonias of Advanced Information Security Corporation; Nicolas Collignon of synacktiv; Reno Robert; Spyridon Chatzimichail of OTE Hellenic Telecommunications Organization S.A.; Stephan Borosh of Veris Group, LLC; Stephen Kost of Integrigy;
Steven Seeley (via Beyond Security's SSD program); Sven Blumenstein of Google; Teemu Kaariainen; Ubais PK; and XOR19 of Trend Micro's Zero Day Initiative.

Impact:   A remote user can obtain data on the target system.

A remote authenticated user can modify data on the target system.

A local or remote authenticated user can cause denial of service conditions on the target system.

A local user can obtain elevated privileges on the target system.

Solution:   The vendor has issued a fix as part of the July 2016 Oracle Critical Patch Update.

The vendor's advisory is available at:

http://www.oracle.com/technetwork/security-advisory/cpujul2016-2881720.html

Vendor URL:  www.oracle.com/technetwork/security-advisory/cpujul2016-2881720.html (Links to External Site)
Cause:   Not specified
Underlying OS:  Linux (Any), UNIX (Any), Windows (Any)

Message History:   This archive entry has one or more follow-up message(s) listed below.
Jul 21 2016 (Ubuntu Issues Fix) MySQL Multiple Bugs Let Remote Users Access Data, Remote Authenticated Users Modify Data, Local or Remote Authenticated Users Deny Service, and Local Users Gain Elevated Privileges
Ubuntu has issued a fix for Ubuntu Linux 12.04 LTS, 14.04 LTS, 15.10, and 16.04 LTS.
Jul 25 2016 (Red Hat Issues Fix) MySQL Multiple Bugs Let Remote Users Access Data, Remote Authenticated Users Modify Data, Local or Remote Authenticated Users Deny Service, and Local Users Gain Elevated Privileges
Red Hat has issued a fix for mysql55-mysql for Red Hat Enterprise Linux 6, 6.6, 6.7, 7, 7.1, and 7.2.
Aug 12 2016 (Red Hat Issues Fix) MySQL Multiple Bugs Let Remote Users Access Data, Remote Authenticated Users Modify Data, Local or Remote Authenticated Users Deny Service, and Local Users Gain Elevated Privileges
Red Hat has issued a fix for Red Hat Enterprise Linux 6, 6.6, 6.7, 7, 7.1, and 7.2.
Aug 12 2016 (Red Hat Issues Fix) MySQL Multiple Bugs Let Remote Users Access Data, Remote Authenticated Users Modify Data, Local or Remote Authenticated Users Deny Service, and Local Users Gain Elevated Privileges
Red Hat has issued a fix for Red Hat Enterprise Linux 6, 6.6, 6.7, 7, 7.1, and 7.2.
Aug 12 2016 (Red Hat Issues Fix) MySQL Multiple Bugs Let Remote Users Access Data, Remote Authenticated Users Modify Data, Local or Remote Authenticated Users Deny Service, and Local Users Gain Elevated Privileges
Red Hat has issued a fix for Red Hat Enterprise Linux 7.
Aug 12 2016 (Red Hat Issues Fix) MySQL Multiple Bugs Let Remote Users Access Data, Remote Authenticated Users Modify Data, Local or Remote Authenticated Users Deny Service, and Local Users Gain Elevated Privileges
Red Hat has issued a fix for Red Hat Enterprise Linux 6, 6.6, 6.7, 7, 7.1, and 7.2.



 Source Message Contents



[Original Message Not Available for Viewing]


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2019, SecurityGlobal.net LLC