SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Generic)  >   libarchive Vendors:   libarchive
(Ubuntu Issues Fix) libarchive Integer Overflow in Processing Files Lets Remote Users Execute Arbitrary Code
SecurityTracker Alert ID:  1036310
SecurityTracker URL:  http://securitytracker.com/id/1036310
CVE Reference:   CVE-2016-5844   (Links to External Site)
Date:  Jul 15 2016
Impact:   Execution of arbitrary code via network, User access via network
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): 3.2.0 and prior
Description:   A vulnerability was reported in libarchive. A remote user can cause arbitrary code to be executed on the target system.

A remote user can create a specially crafted file that, when loaded by the target application, will trigger an integer overflow in choose_volume() and execute arbitrary code on the target system.

The original advisory is available at:

https://blog.fuzzing-project.org/48-Out-of-bounds-read-and-signed-integer-overflow-in-libarchive.html

Hanno Boeck reported this vulnerability.

Impact:   A remote user can a file that, when processed by the target application, will execute arbitrary code on the target system.
Solution:   Ubuntu has issued a fix.

The Ubuntu advisory is available at:

http://www.ubuntu.com/usn/usn-3033-1

Vendor URL:  www.ubuntu.com/usn/usn-3033-1 (Links to External Site)
Cause:   Boundary error
Underlying OS:  Linux (Ubuntu)
Underlying OS Comments:  12.04 LTS, 14.04 LTS, 15.10, 16.04 LTS

Message History:   This archive entry is a follow-up to the message listed below.
Jun 25 2016 libarchive Integer Overflow in Processing Files Lets Remote Users Execute Arbitrary Code



 Source Message Contents



[Original Message Not Available for Viewing]


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2019, SecurityGlobal.net LLC