SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Web Server/CGI)  >   Squid Vendors:   Squid-cache.org
(Ubuntu Issues Fix) Squid ESI Response Processing Bugs Let Remote Users Deny Service
SecurityTracker Alert ID:  1036073
SecurityTracker URL:  http://securitytracker.com/id/1036073
CVE Reference:   CVE-2016-4555, CVE-2016-4556   (Links to External Site)
Date:  Jun 9 2016
Impact:   Denial of service via network
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): 3.x - 3.5.17, 4.x - 4.0.9
Description:   Two vulnerabilities were reported in Squid. A remote user can cause denial of service conditions on the target system.

A remote server can return specially crafted ESI response data to trigger pointer handling errors and cause denial of service conditions on all connected clients.

The vulnerabilities reside in 'client_side_request.cc' [CVE-2016-4555] and 'esi.cc' [CVE-2016-4556].

"bfek-18" and "@vftable" reported these vulnerabilities.

Impact:   A remote server can cause denial of service conditions on all connected clients.
Solution:   Ubuntu has issued a fix.

The Ubuntu advisory is available at:

http://www.ubuntu.com/usn/usn-2995-1

Vendor URL:  www.ubuntu.com/usn/usn-2995-1 (Links to External Site)
Cause:   Access control error
Underlying OS:  Linux (Ubuntu)
Underlying OS Comments:  12.04 LTS, 14.04 LTS, 15.10, 16.04 LTS

Message History:   This archive entry is a follow-up to the message listed below.
May 6 2016 Squid ESI Response Processing Bugs Let Remote Users Deny Service



 Source Message Contents



[Original Message Not Available for Viewing]


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2021, SecurityGlobal.net LLC