SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Web Server/CGI)  >   Squid Vendors:   Squid-cache.org
(Ubuntu Issues Fix) Squid Host Header Processing Lets Remote Users Bypass Security and Poison the Proxy Cache
SecurityTracker Alert ID:  1036071
SecurityTracker URL:  http://securitytracker.com/id/1036071
CVE Reference:   CVE-2016-4553   (Links to External Site)
Date:  Jun 9 2016
Impact:   Modification of system information
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): 3.2.0.11 - 3.5.17, 4.x - 4.0.9
Description:   A vulnerability was reported in Squid. A remote user can poison the proxy cache.

A remote user can submit a specially crafted Host header value to bypass security policy and poison the proxy cache and any downstream caches.

Jianjun Chen from Tsinghua University reported this vulnerability.

Impact:   A remote user may be able to poison the proxy cache and downstream caches with arbitrary content.
Solution:   Ubuntu has issued a fix.

The Ubuntu advisory is available at:

http://www.ubuntu.com/usn/usn-2995-1

Vendor URL:  www.ubuntu.com/usn/usn-2995-1 (Links to External Site)
Cause:   Input validation error
Underlying OS:  Linux (Ubuntu)
Underlying OS Comments:  12.04 LTS, 14.04 LTS, 15.10, 16.04 LTS

Message History:   This archive entry is a follow-up to the message listed below.
May 6 2016 Squid Host Header Processing Lets Remote Users Bypass Security and Poison the Proxy Cache



 Source Message Contents



[Original Message Not Available for Viewing]


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2021, SecurityGlobal.net LLC