SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Web Browser)  >   Google Chrome Vendors:   Google
Google Chrome Multiple Flaws Lets Remote Users Bypass Same-Origin Restrictions, Obtain Potentially Sensitive Information, and Execute Arbitrary Code
SecurityTracker Alert ID:  1035981
SecurityTracker URL:  http://securitytracker.com/id/1035981
CVE Reference:   CVE-2016-1672, CVE-2016-1673, CVE-2016-1674, CVE-2016-1675, CVE-2016-1676, CVE-2016-1677, CVE-2016-1678, CVE-2016-1679, CVE-2016-1680, CVE-2016-1681, CVE-2016-1682, CVE-2016-1683, CVE-2016-1684, CVE-2016-1685, CVE-2016-1686, CVE-2016-1687, CVE-2016-1688, CVE-2016-1689, CVE-2016-1690, CVE-2016-1691, CVE-2016-1692, CVE-2016-1693, CVE-2016-1694, CVE-2016-1695   (Links to External Site)
Date:  May 27 2016
Impact:   Disclosure of system information, Disclosure of user information, Execution of arbitrary code via network, User access via network
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): prior to 51.0.2704.63
Description:   Multiple vulnerabilities were reported in Google Chrome. A remote user can cause arbitrary code to be executed on the target user's system. A remote user can bypass security controls on the target system. A remote user can obtain potentially sensitive information on the target system.

A remote user can bypass same-origin or other policy restrictions on the target system.

Blink is affected [CVE-2016-1672, CVE-2016-1673, CVE-2016-1675].

Extensions is affected [CVE-2016-1674].

Extension bindings is affected [CVE-2016-1676].

A CSP bypass may occur in ServiceWorker [CVE-2016-1682].

A limited cross-origin bypass may occur in ServiceWorker [CVE-2016-1692].

A remote user can create specially crafted content that, when loaded by the target user, will execute arbitrary code on the target user's system.

A type confusion error may occur in the V8 engine [CVE-2016-1677].

A heap overflow may occur in the V8 engine [CVE-2016-1678].

A use-after-free heap memory error may occur in V8 bindings [CVE-2016-1679].

A use-after-free heap memory error may occur in Skia [CVE-2016-1680].

A heap overflow may occur in PDFium [CVE-2016-1681].

An out-of-bounds memory access may occur in libxslt [CVE-2016-1683].

An integer overflow may occur in libxslt [CVE-2016-1684].

A heap overflow may occur in media [CVE-2016-1689].

A use-after-free heap memory error may occur in Autofill [CVE-2016-1690].

A heap overflow may occur in Skia [CVE-2016-1691].

A remote user can obtain potentially sensitive information on the target system.

An out-of-bounds memory read may occur in PDFium [CVE-2016-1685, CVE-2016-1686].

An information leak may occur in extensions [CVE-2016-1687].

An out-of-bounds memory read may occur in the V8 engine [CVE-2016-1688].

The Software Removal Tool can be downloaded via non-secure HTTP [CVE-2016-1693].

HPKP pins are removed when the cache is cleared [CVE-2016-1694].

Various other errors may occur [CVE-2016-1695].

Mariusz Mlynski, Rob Wu, Guang Gong of Qihoo 360, Christian Holler, Atte Kettunen of OUSPG, Aleksandar Nikolic of Cisco Talos, KingstonTime, Nicolas Gregoire, Ke Liu of Tencent's Xuanwu LAB, Til Jasper Ullrich, Max Korenko, Khalil Zhani, Ryan Lester, and Bryant Zadegan reported these vulnerabilities.

Impact:   A remote user can create content that, when loaded by the target user, will execute arbitrary code on the target user's system.

A remote user can bypass security controls on the target system.

A remote user can obtain potentially sensitive information on the target system.

Solution:   The vendor has issued a fix (51.0.2704.63).

The vendor's advisory is available at:

http://googlechromereleases.blogspot.com/2016/05/stable-channel-update_25.html

Vendor URL:  googlechromereleases.blogspot.com/2016/05/stable-channel-update_25.html (Links to External Site)
Cause:   Access control error, Boundary error
Underlying OS:  Linux (Any), UNIX (macOS/OS X), Windows (Any)

Message History:   This archive entry has one or more follow-up message(s) listed below.
Jul 19 2016 (Apple Issues Fix for Apple Watch) Google Chrome Multiple Flaws Lets Remote Users Bypass Same-Origin Restrictions, Obtain Potentially Sensitive Information, and Execute Arbitrary Code
Apple has issued a fix for Apple Watch.
Jul 19 2016 (Apple Issues Fix for Apple TV) Google Chrome Multiple Flaws Lets Remote Users Bypass Same-Origin Restrictions, Obtain Potentially Sensitive Information, and Execute Arbitrary Code
Apple has issued a fix for Apple TV.
Jul 19 2016 (Apple Issues Fix for Apple iTunes) Google Chrome Multiple Flaws Lets Remote Users Bypass Same-Origin Restrictions, Obtain Potentially Sensitive Information, and Execute Arbitrary Code
Apple has issued a fix for Apple iTunes for Windows.



 Source Message Contents



[Original Message Not Available for Viewing]


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2019, SecurityGlobal.net LLC