SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Generic)  >   phpMyAdmin Vendors:   phpMyAdmin Development Team
phpMyAdmin Error Reporting Component Flaw Lets Remote Users Determine the Size of Arbitrary Files on the Target System
SecurityTracker Alert ID:  1035980
SecurityTracker URL:  http://securitytracker.com/id/1035980
CVE Reference:   CVE-2016-5098   (Links to External Site)
Date:  May 27 2016
Impact:   Disclosure of system information, Disclosure of user information
Fix Available:  Yes  Vendor Confirmed:  Yes  

Description:   A vulnerability was reported in phpMyAdmin. A remote user can obtain potentially sensitive information on the target system.

A remote user that can monitor the network and intercept data can modify the target user's HTTP POST data to exploit a flaw in the error reporting component and determine the size of arbitrary files on the target system.

Impact:   A remote user can obtain potentially sensitive information on the target system.
Solution:   The vendor has issued a source code fix, available at:

https://github.com/phpmyadmin/phpmyadmin/commit/d2dc9481d2af25b035778c67eaf0bfd2d2c59dd8

[Editor's note: Released versions are not affected. Only the git 'master' branch was affected.]

The vendor's advisory is available at:

https://www.phpmyadmin.net/security/PMASA-2016-15/

Vendor URL:  www.phpmyadmin.net/security/PMASA-2016-15/ (Links to External Site)
Cause:   Access control error
Underlying OS:  Linux (Any), UNIX (Any), Windows (Any)

Message History:   None.


 Source Message Contents



[Original Message Not Available for Viewing]


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2020, SecurityGlobal.net LLC