Keep Track of the Latest Vulnerabilities
with SecurityTracker!
    Home    |    View Topics    |    Search    |    Contact Us    |   


Try our Premium Alert Service
Sign Up
Sign Up for Your FREE Weekly SecurityTracker E-mail Alert Summary
Instant Alerts
Buy our Premium Vulnerability Notification Service to receive customized, instant alerts
Put SecurityTracker Vulnerability Alerts on Your Web Site -- It's Free!
Become a Partner and License Our Database or Notification Service

Category:   Application (Generic)  >   curl Vendors:
cURL mbedTLS/PolarSSL Function Usage Error Lets Remote Users Bypass Certificate Validation
SecurityTracker Alert ID:  1035907
SecurityTracker URL:
CVE Reference:   CVE-2016-3739   (Links to External Site)
Date:  May 18 2016
Impact:   Modification of system information
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): 7.21.0 - 7.48.0
Description:   A vulnerability was reported in cURL. A remote user can bypass certification validation in certain cases.

The *sslsethostname() functions of mbedTLS/PolarSSL is not properly invoked. On systems with libcurl built to use mbedTLS/PolarSSL, libcurl does not check TLS connection server certificates when the host is specified via IP address or when explicitly using SSLv3.

A remote user that can cause a connection via IP address can conduct a server spoofing attack or a man-in-the-middle attack.

Moti Avrahami reported this vulnerability.

Impact:   A remote user can bypass certification validation on the target system.
Solution:   The vendor has issued a fix (7.49.0).

The vendor's advisory is available at:

Vendor URL: (Links to External Site)
Cause:   State error
Underlying OS:  Linux (Any), UNIX (Any), Windows (Any)

Message History:   None.

 Source Message Contents

[Original Message Not Available for Viewing]

Go to the Top of This SecurityTracker Archive Page

Home   |    View Topics   |    Search   |    Contact Us

Copyright 2018, LLC