SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   OS (Other)  >   Apple iOS Vendors:   Apple
(Apple Issues Fix for Apple iOS) Apple Safari Bugs Let Remote Users Obtain Potentially Sensitive Information Execute Arbitrary Code
SecurityTracker Alert ID:  1035889
SecurityTracker URL:  http://securitytracker.com/id/1035889
CVE Reference:   CVE-2016-1849, CVE-2016-1854, CVE-2016-1855, CVE-2016-1856, CVE-2016-1857, CVE-2016-1858, CVE-2016-1859   (Links to External Site)
Date:  May 17 2016
Impact:   Disclosure of system information, Disclosure of user information, Execution of arbitrary code via network, User access via network
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): prior to 9.3.2
Description:   Multiple vulnerabilities were reported in Apple Safari. A remote user can cause arbitrary code to be executed on the target user's system. A remote user can obtain potentially sensitive information on the target system. Apple iOS is affected.

The "Clear History and Website Data" function may not fully delete browsing history [CVE-2016-1849].

A remote user can create a specially crafted SVG image that, when loaded by the target user, will disclose potentially sensitive information from a different website to the remote user [CVE-2016-1858].

A remote user can create specially crafted HTML that, when loaded by the target user, will trigger a memory corruption error and execute arbitrary code on the target user's system [CVE-2016-1854, CVE-2016-1855, CVE-2016-1856, CVE-2016-1857, CVE-2016-1859].

Jeonghoon Shin@A.D.D, Liang Chen, Zhen Feng, and wushi of KeenLab, Tencent (via Trend Micro's Zero Day Initiative), Tongbo Luo and Bo Qu of Palo Alto Networks, lokihardt working (via Trend Micro's Zero Day Initiative), Anonymous (via Trend Micro's Zero Day Initiative), Liang Chen and wushi of KeenLab, Tencent (via Trend Micro's Zero Day Initiative), Adham Ghrayeb, and an anonymous researcher reported these vulnerabilities.

Impact:   A remote user can create content that, when loaded by the target user, will execute arbitrary code on the target user's system.

A remote user can obtain potentially sensitive information on the target system.

Solution:   Apple has issued a fix for CVE-2016-1849, CVE-2016-1854, CVE-2016-1855, CVE-2016-1856, CVE-2016-1857, CVE-2016-1858, and CVE-2016-1859 for Apple iOS (9.3.2).

The Apple advisory is available at:

https://support.apple.com/en-us/HT206568

Vendor URL:  support.apple.com/en-us/HT206568 (Links to External Site)
Cause:   Access control error

Message History:   This archive entry is a follow-up to the message listed below.
May 17 2016 Apple Safari Bugs Let Remote Users Obtain Potentially Sensitive Information Execute Arbitrary Code



 Source Message Contents



[Original Message Not Available for Viewing]


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2020, SecurityGlobal.net LLC