SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Generic)  >   IBM SPSS Vendors:   IBM
IBM SPSS Buffer Overflow in ActiveX Control Lets Remote Users Execute Arbitrary Code
SecurityTracker Alert ID:  1035867
SecurityTracker URL:  http://securitytracker.com/id/1035867
CVE Reference:   CVE-2015-8530   (Links to External Site)
Date:  May 11 2016
Impact:   Execution of arbitrary code via network, User access via network
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): 20.0, 21.0, 22.0, 23.0, 24.0
Description:   A vulnerability was reported in IBM SPSS. A remote user can cause arbitrary code to be executed on the target user's system.

A remote user can create specially crafted HTML that, when loaded by the target user, will invoke an ActiveX control and trigger a buffer overflow to execute arbitrary code on the target user's system.

Wei Gao at IXIA reported this vulnerability.

Impact:   A remote user can create content that, when loaded by the target user, will execute arbitrary code on the target user's system.
Solution:   IBM has issued a fix.

For 20.0.0.2: 20.0.0.2-IF0008
For 21.0.0.2: 21.0.0.2-IF0010
For 22.0.0.2: 22.0.0.2-IF0011
For 23.0.0.3: 23.0.0.3-IF0001
For 24.0.0.0: 24.0.0.0-IF0003

The IBM advisory is available at:

http://www-01.ibm.com/support/docview.wss?uid=swg21982035

Vendor URL:  www-01.ibm.com/support/docview.wss?uid=swg21982035 (Links to External Site)
Cause:   Boundary error
Underlying OS:  Windows (Any)

Message History:   None.


 Source Message Contents



[Original Message Not Available for Viewing]


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2019, SecurityGlobal.net LLC