SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (File Transfer/Sharing)  >   Samba Vendors:   Samba.org
(HP Issues Fix) Samba Multiple Flaws Let Remote Users Access Data and Files, Obtain Potentially Sensitive Information, and Deny Service
SecurityTracker Alert ID:  1035850
SecurityTracker URL:  http://securitytracker.com/id/1035850
CVE Reference:   CVE-2015-5252, CVE-2015-5296, CVE-2015-5299   (Links to External Site)
Date:  May 11 2016
Impact:   Denial of service via network, Disclosure of system information, Disclosure of user information
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): prior to versions 4.1.22, 4.2.7, 4.3.3
Description:   Multiple vulnerabilities were reported in Samba. A remote user can access data on the target system. A remote user can consume excessive CPU resources on the target system. A remote user can cause the target system to crash. A remote user can obtain files on the target system. A remote user can obtain potentially sensitive information on the target system.

A remote user can send a specially crafted request to the target Samba LDAP server to consume excessive CPU resources on the target system and cause the LDAP server to become unresponsive [CVE-2015-3223]. Versions 4.0.0 through 4.3.2 are affected.

Thilo Uttendorfer of Linux Information Systems AG reported this vulnerability.

The smbd server does not properly verify symbolic links (symlinks). In certain situations, a remote user can access files located outside of the exported share path [CVE-2015-5252]. Versions 3.0.0 through 4.3.2 are affected.

Jan 'Yenya' Kasprzak and the Computer Systems Unit team at Faculty of Informatics, Masaryk University reported this vulnerability.

The system does not properly negotiate signing when establishing an encrypted connection. A remote user that can conduct a man-in-the-middle attack can downgrade the connection and then connect via an unsigned, unencrypted connection [CVE-2015-5296]. Versions 3.2.0 through 4.3.2 are affected.

Stefan Metzmacher of SerNet (www.sernet.com) and the Samba Team reported this vulnerability.

The vfs_shadow_copy2 module does not properly enforce access controls. A remote user without the DIRECTORY_LIST access rights can view the current snapshots [CVE-2015-5299]. Versions 3.2.0 through 4.3.2 are affected.

A remote user can send specially crafted packets to cause the LDAP server in the target samba daemon process to return portions of heap memory [CVE-2015-5330]. Versions 4.0.0 through 4.3.2 are affected.

Douglas Bagnall of Catalyst (www.catalyst.net.nz) reported this vulnerability.

A remote authenticated non-administrative user can bypass the quota limit and create excessive accounts on the target system [CVE-2015-8467]. Versions 4.0.0 through 4.3.2 are affected.

A domain environment with Samba and Windows Active Directory Domain Controllers is affected.

Impact:   A remote user can obtain snapshot data on the target system.

A remote user can consume excessive CPU resources on the target system and cause the target LDAP service to become unresponsive.

A remote user can cause the target system to crash.

A remote user can obtain files on the target system that are located outside of the share path.

A remote user can obtain potentially sensitive information on the target system.

Solution:   HP has issued a fix for CVE-2015-5252, CVE-2015-5296, and CVE-2015-5299.

The HP advisory is available at:

https://h20564.www2.hpe.com/portal/site/hpsc/public/kb/docDisplay?docId=emr_na-c05115993

Cause:   Access control error, Resource error
Underlying OS:  UNIX (HP/UX)
Underlying OS Comments:  11.31

Message History:   This archive entry is a follow-up to the message listed below.
Dec 18 2015 Samba Multiple Flaws Let Remote Users Access Data and Files, Obtain Potentially Sensitive Information, and Deny Service



 Source Message Contents

Subject:  [security bulletin] HPSBUX03574 rev.1 - HPE HP-UX CIFS-Server (Samba), Remote Access Restriction Bypass, Authentication bypass, Denial of Service (DoS), Unauthorized Access to Files, Access Restriction Bypass, Unauthorized Information Disclosure

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Note: the current version of the following document is available here:
https://h20564.www2.hpe.com/portal/site/hpsc/public/kb/docDisplay?docId=emr_n
a-c05115993

SUPPORT COMMUNICATION - SECURITY BULLETIN

Document ID: c05115993
Version: 1

HPSBUX03574 rev.1 - HPE HP-UX CIFS-Server (Samba), Remote Access Restriction
Bypass, Authentication bypass, Denial of Service (DoS), Unauthorized Access
to Files, Access Restriction Bypass, Unauthorized Information Disclosure

NOTICE: The information in this Security Bulletin should be acted upon as
soon as possible.

Release Date: 2016-05-09
Last Updated: 2016-05-09

Potential Security Impact: Remote access restriction bypass, authentication
bypass Denial of Service (DoS), unauthorized access to files, access
restriction bypass, unauthorized information disclosure

Source: Hewlett Packard Enterprise, Product Security Response Team

VULNERABILITY SUMMARY
Potential security vulnerabilities have been identified with HP-UX
CIFS-Server (Samba). The vulnerabilities could be exploited remotely to cause
access restriction bypass, authentication bypass, Denial of Service (DoS),
unauthorized access to files, access restriction bypass, or unauthorized
information disclosure.

References:

CVE-2015-5252
CVE-2015-5296
CVE-2015-5299
CVE-2014-0178
CVE-2013-4496
CVE-2013-4475
CVE-2013-0213
CVE-2013-0214
CVE-2014-0244
CVE-2014-3493
PSRT110074

SUPPORTED SOFTWARE VERSIONS*: ONLY impacted versions are listed.
HP-UX Common Internet File System (CIFS), Client/Server Software All Versions
prior to 03.02.04

BACKGROUND

CVSS 2.0 Base Metrics
===========================================================
  Reference              Base Vector             Base Score
CVE-2015-5252    (AV:N/AC:L/Au:N/C:N/I:P/A:N)       5.0
CVE-2015-5296    (AV:N/AC:M/Au:N/C:N/I:P/A:N)       4.3
CVE-2015-5299    (AV:N/AC:L/Au:N/C:P/I:N/A:N)       5.0
CVE-2014-0178    (AV:N/AC:M/Au:S/C:P/I:N/A:N)       3.5
CVE-2013-4496    (AV:N/AC:L/Au:N/C:P/I:N/A:N)       5.0
CVE-2013-4475    (AV:N/AC:H/Au:N/C:P/I:P/A:N)       4.0
CVE-2013-0213    (AV:N/AC:H/Au:N/C:P/I:P/A:P)       5.1
CVE-2013-0214    (AV:N/AC:H/Au:N/C:P/I:P/A:P)       5.1
CVE-2014-0244    (AV:A/AC:L/Au:N/C:N/I:N/A:P)       3.3
CVE-2014-3493    (AV:A/AC:L/Au:S/C:N/I:N/A:P)       2.7
===========================================================
             Information on CVSS is documented
            in HP Customer Notice: HPSN-2008-002

RESOLUTION

HPE has provided the following software updates to resolve the
vulnerabilities.

Updates are available for download from: https://h20392.www2.hpe.com/portal/s
wdepot/displayProductInfo.do?productNumber=B8725AA

HP-UX CIFS-Server (Samba):- A.03.02.06HP-UX Release :- 11iv3Samba Depot name
:- HP_UX_11.31_CIFS-SERVER_A.03.02.06_HP-UX_B.11.31_IA_PA.depot

MANUAL ACTIONS: Yes - UpdateInstall HP-UX CIFS-Server (Samba) A.03.02.06 or
subsequent for 11i v3

PRODUCT SPECIFIC INFORMATION

HP-UX Software Assistant: HP-UX Software Assistant is an enhanced application
which replaces HP-UX Security Patch Check. It analyzes all Security Bulletins
issued by HP and lists recommended actions that may apply to a specific HP-UX
system. It can also download patches and create a depot automatically. For
more information see: https://h20392.www2.hpe.com/portal/swdepot/displayProdu
ctInfo.do?productNumber=B6834AA

The following text is for use by the HP-UX Software Assistant.

AFFECTED VERSIONS

HP-UX B.11.31 IA/PA
===================
CIFS-Development.CIFS-PRG
CIFS-Server.CIFS-ADMIN
CIFS-Server.CIFS-DOC
CIFS-Server.CIFS-LIB
CIFS-Server.CIFS-RUN
CIFS-Server.CIFS-UTIL
action: install REVISION A.03.02.06 or subsequent

END AFFECTED VERSIONS

HISTORY
Version:1 (rev.1) - 9 May 2016 Initial release

Third Party Security Patches: Third party security patches that are to be
installed on systems running Hewlett Packard Enterprise (HPE) software
products should be applied in accordance with the customer's patch management
policy.

Support: For issues about implementing the recommendations of this Security
Bulletin, contact normal HPE Services support channel. For other issues about
the content of this Security Bulletin, send e-mail to security-alert@hpe.com.

Report: To report a potential security vulnerability with any HPE supported
product, send Email to: security-alert@hpe.com

Subscribe: To initiate a subscription to receive future HPE Security Bulletin
alerts via Email: http://www.hpe.com/support/Subscriber_Choice

Security Bulletin Archive: A list of recently released Security Bulletins is
available here: http://www.hpe.com/support/Security_Bulletin_Archive

Software Product Category: The Software Product Category is represented in
the title by the two characters following HPSB.

3C = 3COM
3P = 3rd Party Software
GN = HPE General Software
HF = HPE Hardware and Firmware
MU = Multi-Platform Software
NS = NonStop Servers
OV = OpenVMS
PV = ProCurve
ST = Storage Software
UX = HP-UX

Copyright 2016 Hewlett Packard Enterprise

Hewlett Packard Enterprise shall not be liable for technical or editorial
errors or omissions contained herein. The information provided is provided
"as is" without warranty of any kind. To the extent permitted by law, neither
HP or its affiliates, subcontractors or suppliers will be liable for
incidental,special or consequential damages including downtime cost; lost
profits; damages relating to the procurement of substitute products or
services; or damages for loss of data, or software restoration. The
information in this document is subject to change without notice. Hewlett
Packard Enterprise and the names of Hewlett Packard Enterprise products
referenced herein are trademarks of Hewlett Packard Enterprise in the United
States and other countries. Other product and company names mentioned herein
may be trademarks of their respective owners.

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1

iQEcBAEBAgAGBQJXMPeqAAoJEGIGBBYqRO9/zHsIANyonX1XeeOexye5pxXCDyig
CeWNkYT/b6O1YNRlvKbM8G+shRcdd/zhUe2J7st/0TND1gw8UpKzxiA8GDwxG84V
VoVbFnp/x1zpDbG9zvjpbb/g858HkWttnOar6TfOouBxTssRLKgMku0wcga75IYz
n41Y29AE9sZbLKSKPGDS8o0qwCuE4WfNLUMop1VezFfx+zS7+AXntXpkPJh1op0G
m1ZMF0HW/3oWTjt9PQgFRdzj4LgSPcdOlkF6lbyJJnXlPwqVdXiOSITVQT5o+vT6
ByihcG+epHj3dteclkJvp3dc6mjCMjB1FPn/0XsxYLLE///0iYxHfiW6hPkapR4=
=WYza
-----END PGP SIGNATURE-----
 
 


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2020, SecurityGlobal.net LLC