SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Device (VoIP/Phone/FAX)  >   Cisco IP Phones Vendors:   Cisco
(Cisco Issues Advisory for Cisco IP Phones) OpenSSL Multiple Bugs Let Remote Users Decrypt Data, Deny Service, Obtain Potentially Sensitive Information, and Potentially Execute Arbitrary Code
SecurityTracker Alert ID:  1035801
SecurityTracker URL:  http://securitytracker.com/id/1035801
CVE Reference:   CVE-2016-2105, CVE-2016-2106, CVE-2016-2107, CVE-2016-2108, CVE-2016-2109, CVE-2016-2176   (Links to External Site)
Date:  May 9 2016
Impact:   Denial of service via local system, Denial of service via network, Disclosure of system information, Disclosure of user information, Execution of arbitrary code via local system, Execution of arbitrary code via network, User access via local system, User access via network
Vendor Confirmed:  Yes  

Description:   Multiple vulnerabilities were reported in OpenSSL. A remote user can decrypt data in certain cases. A remote or local user can cause denial of service conditions. A remote user can obtain potentially sensitive information on the target system. A remote or local user may be able to execute arbitrary code on the target application using OpenSSL. Cisco IP Phones is affected.

A remote user that can conduct a man-in-the-middle attack can conduct a padding oracle attack against data encrypted with an AES CBC cipher when the target server supports AES-NI to decrypt the data [CVE-2016-2107].

[Editor's note: This vulnerability was introduced in fix for a previous vulnerability known as the Lucky 13 padding attack (CVE-2013-0169).]

Juraj Somorovsky reported this vulnerability.

A remote or local user can supply specially crafted data to trigger an overflow in the EVP_EncodeUpdate() function and cause a heap corruption and cause the target application to crash or potentially execute arbitrary code [CVE-2016-2105]. Applications that call the affected PEM_write_bio* functions may be affected.

Guido Vranken reported this vulnerability.

A remote or local user can supply specially crafted data to trigger an overflow in the EVP_EncryptUpdate() function and cause a heap corruption and cause the target application to crash or potentially execute arbitrary code [CVE-2016-2106]. Applications that call the affected function may be affected.

Guido Vranken reported this vulnerability.

A remote or local user can supply specially crafted ASN.1 data to an application that reads data from a BIO using functions such as d2i_CMS_bio() to trigger a memory allocation error and consume excessive memory on the target system [CVE-2016-2109]. TLS applications are not affected.

Brian Carpenter reported this vulnerability.

An application can supply a specially crafted ASN.1 string longer than 1024 bytes to the X509_NAME_oneline() function on EBCDIC systems to trigger a memory over-read and return arbitrary stack data containing potentially sensitive information [CVE-2016-2176].

Guido Vranken reported this vulnerability.

Impact:   A remote user can decrypt traffic in certain cases.

A remote or local user may be able to execute arbitrary code on the target application that uses OpenSSL.

A remote or local user can cause denial of service conditions on the target system.

A remote user can obtain potentially sensitive information on the target system.

Solution:   No solution was available at the time of this entry.

The vendor plans to issue a fix for the following phones:

Cisco 8800 Series IP Phones - VPN Feature (11.5.2; December 12, 2016)
Cisco SPA30X Series IP Phones (7.6.5; April 5, 2017)
Cisco SPA50X Series IP Phones (7.6.5; April 5, 2017)
Cisco SPA51X Series IP Phones (7.6.5; April 5, 2017)
Cisco Unified 6901 IP Phones (9.3(1)SR3; April 5, 2017)

The following phones are also affected, but have no estimated time to fix:

Cisco Unified 6945 IP Phones
Cisco Unified 7800 Series IP Phones
Cisco Unified 8831 series IP Conference Phone
Cisco Unified 8945 IP Phone
Cisco Unified IP Phone 7900 Series

The Cisco advisory is available at:

https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20160504-openssl

Vendor URL:  tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20160504-openssl (Links to External Site)
Cause:   Access control error, Boundary error

Message History:   This archive entry is a follow-up to the message listed below.
May 3 2016 OpenSSL Multiple Bugs Let Remote Users Decrypt Data, Deny Service, Obtain Potentially Sensitive Information, and Potentially Execute Arbitrary Code



 Source Message Contents



[Original Message Not Available for Viewing]


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2019, SecurityGlobal.net LLC