SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Device (Router/Bridge/Hub)  >   Brocade Switch Vendors:   Brocade Communications Systems
(Brocade Communications Systems Issues Fix for Brocade 5600 vRouter) Multiple Vendor TCP Stack Implementations Let Remote Users Deny Service
SecurityTracker Alert ID:  1035758
SecurityTracker URL:  http://securitytracker.com/id/1035758
CVE Reference:   CVE-2004-0230   (Links to External Site)
Date:  May 6 2016
Impact:   Denial of service via network
Fix Available:  Yes  Vendor Confirmed:  Yes  Exploit Included:  Yes  
Version(s): 5600 vRouter
Description:   A vulnerability was reported in several TCP stack implementations. A remote user may be able to cause denial of service conditions using a TCP reset attack. Multiple vendors are affected. Brocade 5600 vRouter is affected.

The UK National Infrastructure Security Co-Ordination Centre (NISCC) reported that some implementations of the Transmission Control Protocol (TCP) are particularly vulnerable to TCP reset attacks. A remote user can cause TCP sessions to terminate prematurely, causing denial of service conditions.

The specific impact on applications that use TCP depends on the mechanisms built into the application to address premature TCP session termination.

According to the report, NISCC considers the Border Gateway Protocol (BGP) to be one of the most affected applications, as it relies on a persistent TCP session between BGP peer entities. Premature termination of an underlying TCP session may require routing tables to be rebuilt and may cause "route flapping". In the case of BGP, using the TCP MD5 Signature Option and anti-spoofing measures can mitigate the vulnerability.

Other applications, such as Domain Name System (DNS) and (Secure Sockets Layer) SSL based applications may also be affected, but to a lesser degree, the report said.

A remote user can reportedly send a TCP packet with the RST (reset) flag set (or the SYN flag) with the appropriate spoofed source and destination IP addresses and TCP ports to cause the TCP session to be terminated. Ordinarily, the remote user may have the probability of 1 in 2^32 of guessing the correct sequence number, the report said. However, in actuality, a remote user may be able to guess an appropriate sequence number with much greater probability because many implementations will accept any sequence number within a certain window of the expected sequence number. The Associate Press reports that the proper number can be guessed within as few as four attempts, requiring only seconds to achieve.

The report credits Paul A. Watson for discovering a practical method for conducting TCP reset attacks (presented in "Slipping In The Window: TCP Reset Attacks" at the CanSecWest 2004 conference).

The report indicates that the following vendors are affected [this is not an inclusive list]:

- Cray Inc. is vulnerable on their UNICOS, UNICOS/mk and UNICOS/mp systems

- Check Point is affected, but has issued a protection mechanism in the latest release for VPN-1/FireWall-1 (R55 HFA-03) that can protect both the firewall device and hosts located behind the firewall.

- Internet Initiative Japan, Inc (IIJ) is affected.

- InterNiche NicheStack and NicheLite are affected.

- Juniper Networks products are affected.

- Cisco products are affected, including IOS and non-IOS based devices.

Other vendors are assessing the impact of this flaw.

The NISCC Vulnerability Advisory 236929 is available at:

http://www.uniras.gov.uk/vuls/2004/236929/index.htm

Impact:   A remote user can cause denial of service on the target TCP session. The specific impact depends on the specific vendor implementation.
Solution:   Brocade Communications Systems has issued a fix for CVE-2004-0230 for Brocade 5600 vRouter (4.2R1).

The Brocade Communications Systems advisory is available at:

http://www.brocade.com/content/dam/common/documents/content-types/security-bulletin/brocade-security-advisory-2016-005.pdf

Vendor URL:  www.brocade.com/content/dam/common/documents/content-types/security-bulletin/brocade-security-advisory-2016-005.pdf (Links to External Site)
Cause:   State error

Message History:   This archive entry is a follow-up to the message listed below.
Apr 20 2004 Multiple Vendor TCP Stack Implementations Let Remote Users Deny Service



 Source Message Contents



[Original Message Not Available for Viewing]


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2019, SecurityGlobal.net LLC