SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (File Transfer/Sharing)  >   Samba Vendors:   Samba.org
(Red Hat Issues Fix) Samba Multiple Flaws Let Remote Users Hijack Connections, Obtain Potentially Sensitive Information, and Deny Service
SecurityTracker Alert ID:  1035547
SecurityTracker URL:  http://securitytracker.com/id/1035547
CVE Reference:   CVE-2015-5370, CVE-2016-2110, CVE-2016-2111, CVE-2016-2112, CVE-2016-2113, CVE-2016-2114, CVE-2016-2115, CVE-2016-2118   (Links to External Site)
Date:  Apr 13 2016
Impact:   Denial of service via network, Disclosure of system information, Disclosure of user information, Modification of user information, User access via network
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): 3.0.0 to 4.4.0
Description:   Multiple vulnerabilities were reported in Samba. A remote user can cause denial of service conditions on the target system. A remote user can hijack connection. A remote user can obtain potentially sensitive information on the target system.

A remote authenticated user can exploit a missing error check in dcesrv_auth_bind_ack() in the DCE/RPC protocol implementation to cause excessive CPU consumption on the target system or cause the target service to crash or execute arbitrary code [CVE-2015-5370]. Versions 3.6.0 to 4.4.0 are affected.

The NTLMSSP implementation is not protected against downgrading. A remote user that can conduct a man-in-the-middle attack can hijack the target connection [CVE-2016-2110].

The NTLMSSP implementation is not protected against downgrading. A remote user that can conduct a man-in-the-middle attack can spoof a system name to a Domain Controller and obtain session-related information about the spoofed system [CVE-2016-2111].

The LDAP implementation does not enforce integrity protection for LDAP connections. A remote user that can conduct a man-in-the-middle attack can downgrade the target LDAP connection to use no integrity protection and gain access to the connection [CVE-2016-2112].

A remote user that can conduct a man-in-the-middle attack can gain access to LDAP connection [CVE-2016-2113]. Versions 4.0.0 to 4.4.0 are affected.

The system does not enforce the mandatory server signing configuration setting. As a result, a remote user can conduct a man-in-the-middle attack to hijack SMB1 connections [CVE-2016-2114]. Versions 4.0.0 to 4.4.0 are affected.

The IPC implementation does not enforce integrity protection by default. A remote user that can conduct a man-in-the-middle attacker can view and modify data sent via the IPC connection [CVE-2016-2115].

A remote user that can conduct a man-in-the-middle attack against DCE/RPE connections can impersonate the target user against the Security Account Manager Remote Protocol (MS-SAMR) and the Local Security Authority (Domain Policy) Remote Protocol (MS-LSAD) implementations to obtain read/write access to the target Security Account Manager database [CVE-2016-2118]. This can be exploited to obtain passwords in the database. Versions 3.6.0 to 4.4.0 are affected.

[Editor's note: Microsoft Windows is also affected by this vulnerability, as described in CVE-2016-0128 (Alert ID 1035534). This vulnerability is known as "Badlock".]

Jouni Knuutinen of Synopsys reported the dcesrv_auth_bind_ack() vulnerability. Stefan Metzmacher of SerNet (https://samba.plus) reported the other vulnerabilities.

Impact:   A remote user can cause denial of service conditions.

A remote user can obtain potentially sensitive information on the target system.

A remote user can hijack connections.

Solution:   Red Hat has issued a fix.

The Red Hat advisory is available at:

https://rhn.redhat.com/errata/RHSA-2016-0618.html

Vendor URL:  rhn.redhat.com/errata/RHSA-2016-0618.html (Links to External Site)
Cause:   Access control error, Authentication error
Underlying OS:  Linux (Red Hat Enterprise)
Underlying OS Comments:  7.1

Message History:   This archive entry is a follow-up to the message listed below.
Apr 13 2016 Samba Multiple Flaws Let Remote Users Hijack Connections, Obtain Potentially Sensitive Information, and Deny Service



 Source Message Contents

Subject:  [RHSA-2016:0618-01] Critical: samba security, bug fix, and enhancement update

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

=====================================================================
                   Red Hat Security Advisory

Synopsis:          Critical: samba security, bug fix, and enhancement update
Advisory ID:       RHSA-2016:0618-01
Product:           Red Hat Enterprise Linux
Advisory URL:      https://rhn.redhat.com/errata/RHSA-2016-0618.html
Issue date:        2016-04-12
Updated on:        2016-04-13
CVE Names:         CVE-2015-5370 CVE-2016-2110 CVE-2016-2111 
                   CVE-2016-2112 CVE-2016-2113 CVE-2016-2114 
                   CVE-2016-2115 CVE-2016-2118 
=====================================================================

1. Summary:

An update for samba is now available for Red Hat Enterprise Linux 7.1
Extended Update Support.

Red Hat Product Security has rated this update as having a security impact
of Critical. A Common Vulnerability Scoring System (CVSS) base score, which
gives a detailed severity rating, is available for each vulnerability from
the CVE link(s) in the References section.

2. Relevant releases/architectures:

Red Hat Enterprise Linux ComputeNode EUS (v. 7.1) - noarch, x86_64
Red Hat Enterprise Linux ComputeNode Optional EUS (v. 7.1) - noarch, x86_64
Red Hat Enterprise Linux Server EUS (v. 7.1) - noarch, ppc64, ppc64le, s390x, x86_64
Red Hat Enterprise Linux Server Optional EUS (v. 7.1) - noarch, ppc64, ppc64le, s390x, x86_64
Red Hat Enterprise Linux Server Resilient Storage EUS (v. 7.1) - x86_64

3. Description:

Samba is an open-source implementation of the Server Message Block (SMB)
protocol and the related Common Internet File System (CIFS) protocol, which
allow PC-compatible machines to share files, printers, and various
information.

The following packages have been upgraded to a newer upstream version:
Samba (4.2.10). Refer to the Release Notes listed in the References section
for a complete list of changes.

Security Fix(es):

* Multiple flaws were found in Samba's DCE/RPC protocol implementation. A
remote, authenticated attacker could use these flaws to cause a denial of
service against the Samba server (high CPU load or a crash) or, possibly,
execute arbitrary code with the permissions of the user running Samba
(root). This flaw could also be used to downgrade a secure DCE/RPC
connection by a man-in-the-middle attacker taking control of an Active
Directory (AD) object and compromising the security of a Samba Active
Directory Domain Controller (DC). (CVE-2015-5370)

Note: While Samba packages as shipped in Red Hat Enterprise Linux do not
support running Samba as an AD DC, this flaw applies to all roles Samba
implements.

* A protocol flaw, publicly referred to as Badlock, was found in the
Security Account Manager Remote Protocol (MS-SAMR) and the Local Security
Authority (Domain Policy) Remote Protocol (MS-LSAD). Any authenticated
DCE/RPC connection that a client initiates against a server could be used
by a man-in-the-middle attacker to impersonate the authenticated user
against the SAMR or LSA service on the server. As a result, the attacker
would be able to get read/write access to the Security Account Manager
database, and use this to reveal all passwords or any other potentially
sensitive information in that database. (CVE-2016-2118)

* Several flaws were found in Samba's implementation of NTLMSSP
authentication. An unauthenticated, man-in-the-middle attacker could use
this flaw to clear the encryption and integrity flags of a connection,
causing data to be transmitted in plain text. The attacker could also force
the client or server into sending data in plain text even if encryption was
explicitly requested for that connection. (CVE-2016-2110)

* It was discovered that Samba configured as a Domain Controller would
establish a secure communication channel with a machine using a spoofed
computer name. A remote attacker able to observe network traffic could use
this flaw to obtain session-related information about the spoofed machine.
(CVE-2016-2111)

* It was found that Samba's LDAP implementation did not enforce integrity
protection for LDAP connections. A man-in-the-middle attacker could use
this flaw to downgrade LDAP connections to use no integrity protection,
allowing them to hijack such connections. (CVE-2016-2112)

* It was found that Samba did not validate SSL/TLS certificates in certain
connections. A man-in-the-middle attacker could use this flaw to spoof a
Samba server using a specially crafted SSL/TLS certificate. (CVE-2016-2113)

* It was discovered that Samba did not enforce Server Message Block (SMB)
signing for clients using the SMB1 protocol. A man-in-the-middle attacker
could use this flaw to modify traffic between a client and a server.
(CVE-2016-2114)

* It was found that Samba did not enable integrity protection for IPC
traffic by default. A man-in-the-middle attacker could use this flaw to
view and modify the data sent between a Samba server and a client.
(CVE-2016-2115)

Red Hat would like to thank the Samba project for reporting these issues.
Upstream acknowledges Jouni Knuutinen (Synopsis) as the original reporter
of CVE-2015-5370; and Stefan Metzmacher (SerNet) as the original reporter
of CVE-2016-2118, CVE-2016-2110, CVE-2016-2112, CVE-2016-2113,
CVE-2016-2114, and CVE-2016-2115.

4. Solution:

For details on how to apply this update, which includes the changes
described in this advisory, refer to:

https://access.redhat.com/articles/11258

After installing this update, the smb service will be restarted
automatically.

5. Bugs fixed (https://bugzilla.redhat.com/):

1309987 - CVE-2015-5370 samba: crash in dcesrv_auth_bind_ack due to missing error check
1311893 - CVE-2016-2110 samba: Man-in-the-middle attacks possible with NTLMSSP authentication
1311902 - CVE-2016-2111 samba: Spoofing vulnerability when domain controller is configured
1311903 - CVE-2016-2112 samba: Missing downgrade detection
1311910 - CVE-2016-2113 samba: Server certificates not validated at client side
1312082 - CVE-2016-2114 samba: Samba based active directory domain controller does not enforce smb signing
1312084 - CVE-2016-2115 samba: Smb signing not required by default when smb client connection is used for ipc usage
1317990 - CVE-2016-2118 samba: SAMR and LSA man in the middle attacks

6. Package List:

Red Hat Enterprise Linux ComputeNode EUS (v. 7.1):

Source:
ipa-4.1.0-18.el7_1.6.src.rpm
libldb-1.1.25-1.el7_1.src.rpm
libtalloc-2.1.5-1.el7_1.src.rpm
libtdb-1.3.8-1.el7_1.src.rpm
libtevent-0.9.26-1.el7_1.src.rpm
samba-4.2.10-5.el7_1.src.rpm

noarch:
samba-common-4.2.10-5.el7_1.noarch.rpm

x86_64:
ipa-client-4.1.0-18.el7_1.6.x86_64.rpm
ipa-debuginfo-4.1.0-18.el7_1.6.x86_64.rpm
ipa-python-4.1.0-18.el7_1.6.x86_64.rpm
libldb-1.1.25-1.el7_1.i686.rpm
libldb-1.1.25-1.el7_1.x86_64.rpm
libldb-debuginfo-1.1.25-1.el7_1.i686.rpm
libldb-debuginfo-1.1.25-1.el7_1.x86_64.rpm
libsmbclient-4.2.10-5.el7_1.i686.rpm
libsmbclient-4.2.10-5.el7_1.x86_64.rpm
libtalloc-2.1.5-1.el7_1.i686.rpm
libtalloc-2.1.5-1.el7_1.x86_64.rpm
libtalloc-debuginfo-2.1.5-1.el7_1.i686.rpm
libtalloc-debuginfo-2.1.5-1.el7_1.x86_64.rpm
libtdb-1.3.8-1.el7_1.i686.rpm
libtdb-1.3.8-1.el7_1.x86_64.rpm
libtdb-debuginfo-1.3.8-1.el7_1.i686.rpm
libtdb-debuginfo-1.3.8-1.el7_1.x86_64.rpm
libtevent-0.9.26-1.el7_1.i686.rpm
libtevent-0.9.26-1.el7_1.x86_64.rpm
libtevent-debuginfo-0.9.26-1.el7_1.i686.rpm
libtevent-debuginfo-0.9.26-1.el7_1.x86_64.rpm
libwbclient-4.2.10-5.el7_1.i686.rpm
libwbclient-4.2.10-5.el7_1.x86_64.rpm
pytalloc-2.1.5-1.el7_1.i686.rpm
pytalloc-2.1.5-1.el7_1.x86_64.rpm
samba-client-4.2.10-5.el7_1.x86_64.rpm
samba-client-libs-4.2.10-5.el7_1.i686.rpm
samba-client-libs-4.2.10-5.el7_1.x86_64.rpm
samba-common-libs-4.2.10-5.el7_1.x86_64.rpm
samba-common-tools-4.2.10-5.el7_1.x86_64.rpm
samba-debuginfo-4.2.10-5.el7_1.i686.rpm
samba-debuginfo-4.2.10-5.el7_1.x86_64.rpm
samba-libs-4.2.10-5.el7_1.i686.rpm
samba-libs-4.2.10-5.el7_1.x86_64.rpm
samba-winbind-4.2.10-5.el7_1.x86_64.rpm
samba-winbind-clients-4.2.10-5.el7_1.x86_64.rpm
samba-winbind-modules-4.2.10-5.el7_1.i686.rpm
samba-winbind-modules-4.2.10-5.el7_1.x86_64.rpm

Red Hat Enterprise Linux ComputeNode Optional EUS (v. 7.1):

noarch:
samba-pidl-4.2.10-5.el7_1.noarch.rpm

x86_64:
ipa-admintools-4.1.0-18.el7_1.6.x86_64.rpm
ipa-debuginfo-4.1.0-18.el7_1.6.x86_64.rpm
ipa-server-4.1.0-18.el7_1.6.x86_64.rpm
ipa-server-trust-ad-4.1.0-18.el7_1.6.x86_64.rpm
ldb-tools-1.1.25-1.el7_1.x86_64.rpm
libldb-debuginfo-1.1.25-1.el7_1.i686.rpm
libldb-debuginfo-1.1.25-1.el7_1.x86_64.rpm
libldb-devel-1.1.25-1.el7_1.i686.rpm
libldb-devel-1.1.25-1.el7_1.x86_64.rpm
libsmbclient-devel-4.2.10-5.el7_1.i686.rpm
libsmbclient-devel-4.2.10-5.el7_1.x86_64.rpm
libtalloc-debuginfo-2.1.5-1.el7_1.i686.rpm
libtalloc-debuginfo-2.1.5-1.el7_1.x86_64.rpm
libtalloc-devel-2.1.5-1.el7_1.i686.rpm
libtalloc-devel-2.1.5-1.el7_1.x86_64.rpm
libtdb-debuginfo-1.3.8-1.el7_1.i686.rpm
libtdb-debuginfo-1.3.8-1.el7_1.x86_64.rpm
libtdb-devel-1.3.8-1.el7_1.i686.rpm
libtdb-devel-1.3.8-1.el7_1.x86_64.rpm
libtevent-debuginfo-0.9.26-1.el7_1.i686.rpm
libtevent-debuginfo-0.9.26-1.el7_1.x86_64.rpm
libtevent-devel-0.9.26-1.el7_1.i686.rpm
libtevent-devel-0.9.26-1.el7_1.x86_64.rpm
libwbclient-devel-4.2.10-5.el7_1.i686.rpm
libwbclient-devel-4.2.10-5.el7_1.x86_64.rpm
pyldb-1.1.25-1.el7_1.i686.rpm
pyldb-1.1.25-1.el7_1.x86_64.rpm
pyldb-devel-1.1.25-1.el7_1.i686.rpm
pyldb-devel-1.1.25-1.el7_1.x86_64.rpm
pytalloc-devel-2.1.5-1.el7_1.i686.rpm
pytalloc-devel-2.1.5-1.el7_1.x86_64.rpm
python-tdb-1.3.8-1.el7_1.i686.rpm
python-tdb-1.3.8-1.el7_1.x86_64.rpm
python-tevent-0.9.26-1.el7_1.x86_64.rpm
samba-4.2.10-5.el7_1.x86_64.rpm
samba-dc-4.2.10-5.el7_1.x86_64.rpm
samba-dc-libs-4.2.10-5.el7_1.x86_64.rpm
samba-debuginfo-4.2.10-5.el7_1.i686.rpm
samba-debuginfo-4.2.10-5.el7_1.x86_64.rpm
samba-devel-4.2.10-5.el7_1.i686.rpm
samba-devel-4.2.10-5.el7_1.x86_64.rpm
samba-python-4.2.10-5.el7_1.x86_64.rpm
samba-test-4.2.10-5.el7_1.x86_64.rpm
samba-test-devel-4.2.10-5.el7_1.x86_64.rpm
samba-test-libs-4.2.10-5.el7_1.i686.rpm
samba-test-libs-4.2.10-5.el7_1.x86_64.rpm
samba-vfs-glusterfs-4.2.10-5.el7_1.x86_64.rpm
samba-winbind-krb5-locator-4.2.10-5.el7_1.x86_64.rpm
tdb-tools-1.3.8-1.el7_1.x86_64.rpm

Red Hat Enterprise Linux Server EUS (v. 7.1):

Source:
ipa-4.1.0-18.el7_1.6.src.rpm
libldb-1.1.25-1.el7_1.src.rpm
libtalloc-2.1.5-1.el7_1.src.rpm
libtdb-1.3.8-1.el7_1.src.rpm
libtevent-0.9.26-1.el7_1.src.rpm
samba-4.2.10-5.el7_1.src.rpm

noarch:
samba-common-4.2.10-5.el7_1.noarch.rpm

ppc64:
ipa-client-4.1.0-18.el7_1.6.ppc64.rpm
ipa-debuginfo-4.1.0-18.el7_1.6.ppc64.rpm
ipa-python-4.1.0-18.el7_1.6.ppc64.rpm
libldb-1.1.25-1.el7_1.ppc.rpm
libldb-1.1.25-1.el7_1.ppc64.rpm
libldb-debuginfo-1.1.25-1.el7_1.ppc.rpm
libldb-debuginfo-1.1.25-1.el7_1.ppc64.rpm
libsmbclient-4.2.10-5.el7_1.ppc.rpm
libsmbclient-4.2.10-5.el7_1.ppc64.rpm
libtalloc-2.1.5-1.el7_1.ppc.rpm
libtalloc-2.1.5-1.el7_1.ppc64.rpm
libtalloc-debuginfo-2.1.5-1.el7_1.ppc.rpm
libtalloc-debuginfo-2.1.5-1.el7_1.ppc64.rpm
libtdb-1.3.8-1.el7_1.ppc.rpm
libtdb-1.3.8-1.el7_1.ppc64.rpm
libtdb-debuginfo-1.3.8-1.el7_1.ppc.rpm
libtdb-debuginfo-1.3.8-1.el7_1.ppc64.rpm
libtevent-0.9.26-1.el7_1.ppc.rpm
libtevent-0.9.26-1.el7_1.ppc64.rpm
libtevent-debuginfo-0.9.26-1.el7_1.ppc.rpm
libtevent-debuginfo-0.9.26-1.el7_1.ppc64.rpm
libwbclient-4.2.10-5.el7_1.ppc.rpm
libwbclient-4.2.10-5.el7_1.ppc64.rpm
pytalloc-2.1.5-1.el7_1.ppc.rpm
pytalloc-2.1.5-1.el7_1.ppc64.rpm
samba-4.2.10-5.el7_1.ppc64.rpm
samba-client-4.2.10-5.el7_1.ppc64.rpm
samba-client-libs-4.2.10-5.el7_1.ppc.rpm
samba-client-libs-4.2.10-5.el7_1.ppc64.rpm
samba-common-libs-4.2.10-5.el7_1.ppc64.rpm
samba-common-tools-4.2.10-5.el7_1.ppc64.rpm
samba-debuginfo-4.2.10-5.el7_1.ppc.rpm
samba-debuginfo-4.2.10-5.el7_1.ppc64.rpm
samba-libs-4.2.10-5.el7_1.ppc.rpm
samba-libs-4.2.10-5.el7_1.ppc64.rpm
samba-winbind-4.2.10-5.el7_1.ppc64.rpm
samba-winbind-clients-4.2.10-5.el7_1.ppc64.rpm
samba-winbind-modules-4.2.10-5.el7_1.ppc.rpm
samba-winbind-modules-4.2.10-5.el7_1.ppc64.rpm

s390x:
ipa-client-4.1.0-18.el7_1.6.s390x.rpm
ipa-debuginfo-4.1.0-18.el7_1.6.s390x.rpm
ipa-python-4.1.0-18.el7_1.6.s390x.rpm
libldb-1.1.25-1.el7_1.s390.rpm
libldb-1.1.25-1.el7_1.s390x.rpm
libldb-debuginfo-1.1.25-1.el7_1.s390.rpm
libldb-debuginfo-1.1.25-1.el7_1.s390x.rpm
libsmbclient-4.2.10-5.el7_1.s390.rpm
libsmbclient-4.2.10-5.el7_1.s390x.rpm
libtalloc-2.1.5-1.el7_1.s390.rpm
libtalloc-2.1.5-1.el7_1.s390x.rpm
libtalloc-debuginfo-2.1.5-1.el7_1.s390.rpm
libtalloc-debuginfo-2.1.5-1.el7_1.s390x.rpm
libtdb-1.3.8-1.el7_1.s390.rpm
libtdb-1.3.8-1.el7_1.s390x.rpm
libtdb-debuginfo-1.3.8-1.el7_1.s390.rpm
libtdb-debuginfo-1.3.8-1.el7_1.s390x.rpm
libtevent-0.9.26-1.el7_1.s390.rpm
libtevent-0.9.26-1.el7_1.s390x.rpm
libtevent-debuginfo-0.9.26-1.el7_1.s390.rpm
libtevent-debuginfo-0.9.26-1.el7_1.s390x.rpm
libwbclient-4.2.10-5.el7_1.s390.rpm
libwbclient-4.2.10-5.el7_1.s390x.rpm
pytalloc-2.1.5-1.el7_1.s390.rpm
pytalloc-2.1.5-1.el7_1.s390x.rpm
samba-4.2.10-5.el7_1.s390x.rpm
samba-client-4.2.10-5.el7_1.s390x.rpm
samba-client-libs-4.2.10-5.el7_1.s390.rpm
samba-client-libs-4.2.10-5.el7_1.s390x.rpm
samba-common-libs-4.2.10-5.el7_1.s390x.rpm
samba-common-tools-4.2.10-5.el7_1.s390x.rpm
samba-debuginfo-4.2.10-5.el7_1.s390.rpm
samba-debuginfo-4.2.10-5.el7_1.s390x.rpm
samba-libs-4.2.10-5.el7_1.s390.rpm
samba-libs-4.2.10-5.el7_1.s390x.rpm
samba-winbind-4.2.10-5.el7_1.s390x.rpm
samba-winbind-clients-4.2.10-5.el7_1.s390x.rpm
samba-winbind-modules-4.2.10-5.el7_1.s390.rpm
samba-winbind-modules-4.2.10-5.el7_1.s390x.rpm

x86_64:
ipa-admintools-4.1.0-18.el7_1.6.x86_64.rpm
ipa-client-4.1.0-18.el7_1.6.x86_64.rpm
ipa-debuginfo-4.1.0-18.el7_1.6.x86_64.rpm
ipa-python-4.1.0-18.el7_1.6.x86_64.rpm
ipa-server-4.1.0-18.el7_1.6.x86_64.rpm
ipa-server-trust-ad-4.1.0-18.el7_1.6.x86_64.rpm
libldb-1.1.25-1.el7_1.i686.rpm
libldb-1.1.25-1.el7_1.x86_64.rpm
libldb-debuginfo-1.1.25-1.el7_1.i686.rpm
libldb-debuginfo-1.1.25-1.el7_1.x86_64.rpm
libsmbclient-4.2.10-5.el7_1.i686.rpm
libsmbclient-4.2.10-5.el7_1.x86_64.rpm
libtalloc-2.1.5-1.el7_1.i686.rpm
libtalloc-2.1.5-1.el7_1.x86_64.rpm
libtalloc-debuginfo-2.1.5-1.el7_1.i686.rpm
libtalloc-debuginfo-2.1.5-1.el7_1.x86_64.rpm
libtdb-1.3.8-1.el7_1.i686.rpm
libtdb-1.3.8-1.el7_1.x86_64.rpm
libtdb-debuginfo-1.3.8-1.el7_1.i686.rpm
libtdb-debuginfo-1.3.8-1.el7_1.x86_64.rpm
libtevent-0.9.26-1.el7_1.i686.rpm
libtevent-0.9.26-1.el7_1.x86_64.rpm
libtevent-debuginfo-0.9.26-1.el7_1.i686.rpm
libtevent-debuginfo-0.9.26-1.el7_1.x86_64.rpm
libwbclient-4.2.10-5.el7_1.i686.rpm
libwbclient-4.2.10-5.el7_1.x86_64.rpm
pyldb-1.1.25-1.el7_1.i686.rpm
pyldb-1.1.25-1.el7_1.x86_64.rpm
pytalloc-2.1.5-1.el7_1.i686.rpm
pytalloc-2.1.5-1.el7_1.x86_64.rpm
python-tdb-1.3.8-1.el7_1.i686.rpm
python-tdb-1.3.8-1.el7_1.x86_64.rpm
python-tevent-0.9.26-1.el7_1.x86_64.rpm
samba-4.2.10-5.el7_1.x86_64.rpm
samba-client-4.2.10-5.el7_1.x86_64.rpm
samba-client-libs-4.2.10-5.el7_1.i686.rpm
samba-client-libs-4.2.10-5.el7_1.x86_64.rpm
samba-common-libs-4.2.10-5.el7_1.x86_64.rpm
samba-common-tools-4.2.10-5.el7_1.x86_64.rpm
samba-debuginfo-4.2.10-5.el7_1.i686.rpm
samba-debuginfo-4.2.10-5.el7_1.x86_64.rpm
samba-libs-4.2.10-5.el7_1.i686.rpm
samba-libs-4.2.10-5.el7_1.x86_64.rpm
samba-python-4.2.10-5.el7_1.x86_64.rpm
samba-winbind-4.2.10-5.el7_1.x86_64.rpm
samba-winbind-clients-4.2.10-5.el7_1.x86_64.rpm
samba-winbind-modules-4.2.10-5.el7_1.i686.rpm
samba-winbind-modules-4.2.10-5.el7_1.x86_64.rpm
tdb-tools-1.3.8-1.el7_1.x86_64.rpm

Red Hat Enterprise Linux Server EUS (v. 7.1):

Source:
ipa-4.1.0-18.ael7b_1.6.src.rpm
libldb-1.1.25-1.ael7b_1.src.rpm
libtalloc-2.1.5-1.ael7b_1.src.rpm
libtdb-1.3.8-1.ael7b_1.src.rpm
libtevent-0.9.26-1.ael7b_1.src.rpm
samba-4.2.10-5.ael7b_1.src.rpm

noarch:
samba-common-4.2.10-5.ael7b_1.noarch.rpm

ppc64le:
ipa-admintools-4.1.0-18.ael7b_1.6.ppc64le.rpm
ipa-client-4.1.0-18.ael7b_1.6.ppc64le.rpm
ipa-debuginfo-4.1.0-18.ael7b_1.6.ppc64le.rpm
ipa-python-4.1.0-18.ael7b_1.6.ppc64le.rpm
libldb-1.1.25-1.ael7b_1.ppc64le.rpm
libldb-debuginfo-1.1.25-1.ael7b_1.ppc64le.rpm
libsmbclient-4.2.10-5.ael7b_1.ppc64le.rpm
libtalloc-2.1.5-1.ael7b_1.ppc64le.rpm
libtalloc-debuginfo-2.1.5-1.ael7b_1.ppc64le.rpm
libtdb-1.3.8-1.ael7b_1.ppc64le.rpm
libtdb-debuginfo-1.3.8-1.ael7b_1.ppc64le.rpm
libtevent-0.9.26-1.ael7b_1.ppc64le.rpm
libtevent-debuginfo-0.9.26-1.ael7b_1.ppc64le.rpm
libwbclient-4.2.10-5.ael7b_1.ppc64le.rpm
pytalloc-2.1.5-1.ael7b_1.ppc64le.rpm
samba-4.2.10-5.ael7b_1.ppc64le.rpm
samba-client-4.2.10-5.ael7b_1.ppc64le.rpm
samba-client-libs-4.2.10-5.ael7b_1.ppc64le.rpm
samba-common-libs-4.2.10-5.ael7b_1.ppc64le.rpm
samba-common-tools-4.2.10-5.ael7b_1.ppc64le.rpm
samba-debuginfo-4.2.10-5.ael7b_1.ppc64le.rpm
samba-libs-4.2.10-5.ael7b_1.ppc64le.rpm
samba-winbind-4.2.10-5.ael7b_1.ppc64le.rpm
samba-winbind-clients-4.2.10-5.ael7b_1.ppc64le.rpm
samba-winbind-modules-4.2.10-5.ael7b_1.ppc64le.rpm

Red Hat Enterprise Linux Server Resilient Storage EUS (v. 7.1):

x86_64:
ctdb-4.2.10-5.el7_1.x86_64.rpm
ctdb-devel-4.2.10-5.el7_1.i686.rpm
ctdb-devel-4.2.10-5.el7_1.x86_64.rpm
ctdb-tests-4.2.10-5.el7_1.x86_64.rpm
samba-debuginfo-4.2.10-5.el7_1.i686.rpm
samba-debuginfo-4.2.10-5.el7_1.x86_64.rpm

Red Hat Enterprise Linux Server Optional EUS (v. 7.1):

Source:
openchange-2.0-4.el7_1.1.src.rpm

noarch:
openchange-devel-docs-2.0-4.el7_1.1.noarch.rpm
samba-pidl-4.2.10-5.el7_1.noarch.rpm

ppc64:
ipa-admintools-4.1.0-18.el7_1.6.ppc64.rpm
ipa-debuginfo-4.1.0-18.el7_1.6.ppc64.rpm
ldb-tools-1.1.25-1.el7_1.ppc64.rpm
libldb-debuginfo-1.1.25-1.el7_1.ppc.rpm
libldb-debuginfo-1.1.25-1.el7_1.ppc64.rpm
libldb-devel-1.1.25-1.el7_1.ppc.rpm
libldb-devel-1.1.25-1.el7_1.ppc64.rpm
libsmbclient-devel-4.2.10-5.el7_1.ppc.rpm
libsmbclient-devel-4.2.10-5.el7_1.ppc64.rpm
libtalloc-debuginfo-2.1.5-1.el7_1.ppc.rpm
libtalloc-debuginfo-2.1.5-1.el7_1.ppc64.rpm
libtalloc-devel-2.1.5-1.el7_1.ppc.rpm
libtalloc-devel-2.1.5-1.el7_1.ppc64.rpm
libtdb-debuginfo-1.3.8-1.el7_1.ppc.rpm
libtdb-debuginfo-1.3.8-1.el7_1.ppc64.rpm
libtdb-devel-1.3.8-1.el7_1.ppc.rpm
libtdb-devel-1.3.8-1.el7_1.ppc64.rpm
libtevent-debuginfo-0.9.26-1.el7_1.ppc.rpm
libtevent-debuginfo-0.9.26-1.el7_1.ppc64.rpm
libtevent-devel-0.9.26-1.el7_1.ppc.rpm
libtevent-devel-0.9.26-1.el7_1.ppc64.rpm
libwbclient-devel-4.2.10-5.el7_1.ppc.rpm
libwbclient-devel-4.2.10-5.el7_1.ppc64.rpm
pyldb-1.1.25-1.el7_1.ppc.rpm
pyldb-1.1.25-1.el7_1.ppc64.rpm
pyldb-devel-1.1.25-1.el7_1.ppc.rpm
pyldb-devel-1.1.25-1.el7_1.ppc64.rpm
pytalloc-devel-2.1.5-1.el7_1.ppc.rpm
pytalloc-devel-2.1.5-1.el7_1.ppc64.rpm
python-tdb-1.3.8-1.el7_1.ppc.rpm
python-tdb-1.3.8-1.el7_1.ppc64.rpm
python-tevent-0.9.26-1.el7_1.ppc64.rpm
samba-dc-4.2.10-5.el7_1.ppc64.rpm
samba-dc-libs-4.2.10-5.el7_1.ppc64.rpm
samba-debuginfo-4.2.10-5.el7_1.ppc.rpm
samba-debuginfo-4.2.10-5.el7_1.ppc64.rpm
samba-devel-4.2.10-5.el7_1.ppc.rpm
samba-devel-4.2.10-5.el7_1.ppc64.rpm
samba-python-4.2.10-5.el7_1.ppc64.rpm
samba-test-4.2.10-5.el7_1.ppc64.rpm
samba-test-devel-4.2.10-5.el7_1.ppc64.rpm
samba-test-libs-4.2.10-5.el7_1.ppc.rpm
samba-test-libs-4.2.10-5.el7_1.ppc64.rpm
samba-winbind-krb5-locator-4.2.10-5.el7_1.ppc64.rpm
tdb-tools-1.3.8-1.el7_1.ppc64.rpm

s390x:
ipa-admintools-4.1.0-18.el7_1.6.s390x.rpm
ipa-debuginfo-4.1.0-18.el7_1.6.s390x.rpm
ldb-tools-1.1.25-1.el7_1.s390x.rpm
libldb-debuginfo-1.1.25-1.el7_1.s390.rpm
libldb-debuginfo-1.1.25-1.el7_1.s390x.rpm
libldb-devel-1.1.25-1.el7_1.s390.rpm
libldb-devel-1.1.25-1.el7_1.s390x.rpm
libsmbclient-devel-4.2.10-5.el7_1.s390.rpm
libsmbclient-devel-4.2.10-5.el7_1.s390x.rpm
libtalloc-debuginfo-2.1.5-1.el7_1.s390.rpm
libtalloc-debuginfo-2.1.5-1.el7_1.s390x.rpm
libtalloc-devel-2.1.5-1.el7_1.s390.rpm
libtalloc-devel-2.1.5-1.el7_1.s390x.rpm
libtdb-debuginfo-1.3.8-1.el7_1.s390.rpm
libtdb-debuginfo-1.3.8-1.el7_1.s390x.rpm
libtdb-devel-1.3.8-1.el7_1.s390.rpm
libtdb-devel-1.3.8-1.el7_1.s390x.rpm
libtevent-debuginfo-0.9.26-1.el7_1.s390.rpm
libtevent-debuginfo-0.9.26-1.el7_1.s390x.rpm
libtevent-devel-0.9.26-1.el7_1.s390.rpm
libtevent-devel-0.9.26-1.el7_1.s390x.rpm
libwbclient-devel-4.2.10-5.el7_1.s390.rpm
libwbclient-devel-4.2.10-5.el7_1.s390x.rpm
pyldb-1.1.25-1.el7_1.s390.rpm
pyldb-1.1.25-1.el7_1.s390x.rpm
pyldb-devel-1.1.25-1.el7_1.s390.rpm
pyldb-devel-1.1.25-1.el7_1.s390x.rpm
pytalloc-devel-2.1.5-1.el7_1.s390.rpm
pytalloc-devel-2.1.5-1.el7_1.s390x.rpm
python-tdb-1.3.8-1.el7_1.s390.rpm
python-tdb-1.3.8-1.el7_1.s390x.rpm
python-tevent-0.9.26-1.el7_1.s390x.rpm
samba-dc-4.2.10-5.el7_1.s390x.rpm
samba-dc-libs-4.2.10-5.el7_1.s390x.rpm
samba-debuginfo-4.2.10-5.el7_1.s390.rpm
samba-debuginfo-4.2.10-5.el7_1.s390x.rpm
samba-devel-4.2.10-5.el7_1.s390.rpm
samba-devel-4.2.10-5.el7_1.s390x.rpm
samba-python-4.2.10-5.el7_1.s390x.rpm
samba-test-4.2.10-5.el7_1.s390x.rpm
samba-test-devel-4.2.10-5.el7_1.s390x.rpm
samba-test-libs-4.2.10-5.el7_1.s390.rpm
samba-test-libs-4.2.10-5.el7_1.s390x.rpm
samba-winbind-krb5-locator-4.2.10-5.el7_1.s390x.rpm
tdb-tools-1.3.8-1.el7_1.s390x.rpm

x86_64:
ldb-tools-1.1.25-1.el7_1.x86_64.rpm
libldb-debuginfo-1.1.25-1.el7_1.i686.rpm
libldb-debuginfo-1.1.25-1.el7_1.x86_64.rpm
libldb-devel-1.1.25-1.el7_1.i686.rpm
libldb-devel-1.1.25-1.el7_1.x86_64.rpm
libsmbclient-devel-4.2.10-5.el7_1.i686.rpm
libsmbclient-devel-4.2.10-5.el7_1.x86_64.rpm
libtalloc-debuginfo-2.1.5-1.el7_1.i686.rpm
libtalloc-debuginfo-2.1.5-1.el7_1.x86_64.rpm
libtalloc-devel-2.1.5-1.el7_1.i686.rpm
libtalloc-devel-2.1.5-1.el7_1.x86_64.rpm
libtdb-debuginfo-1.3.8-1.el7_1.i686.rpm
libtdb-debuginfo-1.3.8-1.el7_1.x86_64.rpm
libtdb-devel-1.3.8-1.el7_1.i686.rpm
libtdb-devel-1.3.8-1.el7_1.x86_64.rpm
libtevent-debuginfo-0.9.26-1.el7_1.i686.rpm
libtevent-debuginfo-0.9.26-1.el7_1.x86_64.rpm
libtevent-devel-0.9.26-1.el7_1.i686.rpm
libtevent-devel-0.9.26-1.el7_1.x86_64.rpm
libwbclient-devel-4.2.10-5.el7_1.i686.rpm
libwbclient-devel-4.2.10-5.el7_1.x86_64.rpm
openchange-2.0-4.el7_1.1.i686.rpm
openchange-2.0-4.el7_1.1.x86_64.rpm
openchange-client-2.0-4.el7_1.1.x86_64.rpm
openchange-debuginfo-2.0-4.el7_1.1.i686.rpm
openchange-debuginfo-2.0-4.el7_1.1.x86_64.rpm
openchange-devel-2.0-4.el7_1.1.i686.rpm
openchange-devel-2.0-4.el7_1.1.x86_64.rpm
pyldb-devel-1.1.25-1.el7_1.i686.rpm
pyldb-devel-1.1.25-1.el7_1.x86_64.rpm
pytalloc-devel-2.1.5-1.el7_1.i686.rpm
pytalloc-devel-2.1.5-1.el7_1.x86_64.rpm
samba-dc-4.2.10-5.el7_1.x86_64.rpm
samba-dc-libs-4.2.10-5.el7_1.x86_64.rpm
samba-debuginfo-4.2.10-5.el7_1.i686.rpm
samba-debuginfo-4.2.10-5.el7_1.x86_64.rpm
samba-devel-4.2.10-5.el7_1.i686.rpm
samba-devel-4.2.10-5.el7_1.x86_64.rpm
samba-test-4.2.10-5.el7_1.x86_64.rpm
samba-test-devel-4.2.10-5.el7_1.x86_64.rpm
samba-test-libs-4.2.10-5.el7_1.i686.rpm
samba-test-libs-4.2.10-5.el7_1.x86_64.rpm
samba-vfs-glusterfs-4.2.10-5.el7_1.x86_64.rpm
samba-winbind-krb5-locator-4.2.10-5.el7_1.x86_64.rpm

Red Hat Enterprise Linux Server Optional EUS (v. 7.1):

Source:
openchange-2.0-4.ael7b_1.1.src.rpm

noarch:
openchange-devel-docs-2.0-4.ael7b_1.1.noarch.rpm
samba-pidl-4.2.10-5.ael7b_1.noarch.rpm

ppc64le:
ctdb-4.2.10-5.ael7b_1.ppc64le.rpm
ctdb-devel-4.2.10-5.ael7b_1.ppc64le.rpm
ctdb-tests-4.2.10-5.ael7b_1.ppc64le.rpm
ldb-tools-1.1.25-1.ael7b_1.ppc64le.rpm
libldb-debuginfo-1.1.25-1.ael7b_1.ppc64le.rpm
libldb-devel-1.1.25-1.ael7b_1.ppc64le.rpm
libsmbclient-devel-4.2.10-5.ael7b_1.ppc64le.rpm
libtalloc-debuginfo-2.1.5-1.ael7b_1.ppc64le.rpm
libtalloc-devel-2.1.5-1.ael7b_1.ppc64le.rpm
libtdb-debuginfo-1.3.8-1.ael7b_1.ppc64le.rpm
libtdb-devel-1.3.8-1.ael7b_1.ppc64le.rpm
libtevent-debuginfo-0.9.26-1.ael7b_1.ppc64le.rpm
libtevent-devel-0.9.26-1.ael7b_1.ppc64le.rpm
libwbclient-devel-4.2.10-5.ael7b_1.ppc64le.rpm
openchange-2.0-4.ael7b_1.1.ppc64le.rpm
openchange-client-2.0-4.ael7b_1.1.ppc64le.rpm
openchange-debuginfo-2.0-4.ael7b_1.1.ppc64le.rpm
openchange-devel-2.0-4.ael7b_1.1.ppc64le.rpm
pyldb-1.1.25-1.ael7b_1.ppc64le.rpm
pyldb-devel-1.1.25-1.ael7b_1.ppc64le.rpm
pytalloc-devel-2.1.5-1.ael7b_1.ppc64le.rpm
python-tdb-1.3.8-1.ael7b_1.ppc64le.rpm
python-tevent-0.9.26-1.ael7b_1.ppc64le.rpm
samba-dc-4.2.10-5.ael7b_1.ppc64le.rpm
samba-dc-libs-4.2.10-5.ael7b_1.ppc64le.rpm
samba-debuginfo-4.2.10-5.ael7b_1.ppc64le.rpm
samba-devel-4.2.10-5.ael7b_1.ppc64le.rpm
samba-python-4.2.10-5.ael7b_1.ppc64le.rpm
samba-test-4.2.10-5.ael7b_1.ppc64le.rpm
samba-test-devel-4.2.10-5.ael7b_1.ppc64le.rpm
samba-test-libs-4.2.10-5.ael7b_1.ppc64le.rpm
samba-winbind-krb5-locator-4.2.10-5.ael7b_1.ppc64le.rpm
tdb-tools-1.3.8-1.ael7b_1.ppc64le.rpm

These packages are GPG signed by Red Hat for security.  Our key and
details on how to verify the signature are available from
https://access.redhat.com/security/team/key/

7. References:

https://access.redhat.com/security/cve/CVE-2015-5370
https://access.redhat.com/security/cve/CVE-2016-2110
https://access.redhat.com/security/cve/CVE-2016-2111
https://access.redhat.com/security/cve/CVE-2016-2112
https://access.redhat.com/security/cve/CVE-2016-2113
https://access.redhat.com/security/cve/CVE-2016-2114
https://access.redhat.com/security/cve/CVE-2016-2115
https://access.redhat.com/security/cve/CVE-2016-2118
https://access.redhat.com/security/updates/classification/#critical
https://www.samba.org/samba/history/samba-4.2.10.html
https://access.redhat.com/security/vulnerabilities/badlock
https://access.redhat.com/articles/2253041
http://badlock.org/
https://access.redhat.com/articles/2243351

8. Contact:

The Red Hat security contact is <secalert@redhat.com>. More contact
details at https://access.redhat.com/security/team/contact/

Copyright 2016 Red Hat, Inc.
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1

iD8DBQFXDaJMXlSAg2UNWIIRAr3KAJ9tqHHfeucggbmPZPfiOAc6n2ENSACgxYUr
kQsA3DDmUXrLxoRYXUV6hX8=
=GSXg
-----END PGP SIGNATURE-----


-- 
Enterprise-watch-list mailing list
Enterprise-watch-list@redhat.com
https://www.redhat.com/mailman/listinfo/enterprise-watch-list
 
 


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2021, SecurityGlobal.net LLC