SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Generic)  >   Git Vendors:   kernel.org
(Oracle Issues Fix for Oracle Linux) Git Buffer Overflow Lets Remote Authenticated Users Execute Arbitrary Code
SecurityTracker Alert ID:  1035392
SecurityTracker URL:  http://securitytracker.com/id/1035392
CVE Reference:   CVE-2016-2315, CVE-2016-2324   (Links to External Site)
Date:  Mar 24 2016
Impact:   Execution of arbitrary code via network, User access via network
Fix Available:  Yes  Vendor Confirmed:  Yes  

Description:   Two vulnerabilities were reported in Git. A remote authenticated user can execute arbitrary code on the target system.

A remote authenticated user can push a specially crafted repository to trigger a heap overflow and execute arbitrary code on the target system [CVE-2016-2315].

Lael Cellier (@ytrezq) reported this vulnerability.

A remote authenticated user can push or clone a specially crafted repository to potentially execute arbitrary code on the target system [CVE-2016-2324].

Impact:   A remote authenticated user can execute arbitrary code on the target system.
Solution:   Oracle has issued a fix.

The Oracle Linux advisory is available at:

http://linux.oracle.com/errata/ELSA-2016-0496.html

Vendor URL:  linux.oracle.com/errata/ELSA-2016-0496.html (Links to External Site)
Cause:   Boundary error
Underlying OS:  Linux (Oracle)
Underlying OS Comments:  6, 7

Message History:   This archive entry is a follow-up to the message listed below.
Mar 16 2016 Git Buffer Overflow Lets Remote Authenticated Users Execute Arbitrary Code



 Source Message Contents

Subject:  [El-errata] ELSA-2016-0496 Important: Oracle Linux 7 git security update

Oracle Linux Security Advisory ELSA-2016-0496

http://linux.oracle.com/errata/ELSA-2016-0496.html

The following updated rpms for Oracle Linux 7 have been uploaded to the 
Unbreakable Linux Network:

x86_64:
emacs-git-1.8.3.1-6.el7_2.1.noarch.rpm
emacs-git-el-1.8.3.1-6.el7_2.1.noarch.rpm
git-1.8.3.1-6.el7_2.1.x86_64.rpm
git-all-1.8.3.1-6.el7_2.1.noarch.rpm
git-bzr-1.8.3.1-6.el7_2.1.noarch.rpm
git-cvs-1.8.3.1-6.el7_2.1.noarch.rpm
git-daemon-1.8.3.1-6.el7_2.1.x86_64.rpm
git-email-1.8.3.1-6.el7_2.1.noarch.rpm
git-gui-1.8.3.1-6.el7_2.1.noarch.rpm
git-hg-1.8.3.1-6.el7_2.1.noarch.rpm
git-p4-1.8.3.1-6.el7_2.1.noarch.rpm
git-svn-1.8.3.1-6.el7_2.1.x86_64.rpm
gitk-1.8.3.1-6.el7_2.1.noarch.rpm
gitweb-1.8.3.1-6.el7_2.1.noarch.rpm
perl-Git-1.8.3.1-6.el7_2.1.noarch.rpm
perl-Git-SVN-1.8.3.1-6.el7_2.1.noarch.rpm


SRPMS:
http://oss.oracle.com/ol7/SRPMS-updates/git-1.8.3.1-6.el7_2.1.src.rpm



Description of changes:

[1.8.3.1-6.1]
- fix heap overflow CVE-2016-2315 CVE-2016-2324
   Resolves: #1318254


_______________________________________________
El-errata mailing list
El-errata@oss.oracle.com
https://oss.oracle.com/mailman/listinfo/el-errata
 
 


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2021, SecurityGlobal.net LLC