SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Security)  >   Symantec Endpoint Protection Vendors:   Symantec
Symantec Endpoint Protection Multiple Bugs Let Remote Users Conduct Cross-Site Scripting and SQL Injection Attacks and Let Remote Authenticated Users Gain Elevated Privileges
SecurityTracker Alert ID:  1035329
SecurityTracker URL:  http://securitytracker.com/id/1035329
CVE Reference:   CVE-2015-8152, CVE-2015-8153, CVE-2015-8154   (Links to External Site)
Date:  Mar 18 2016
Impact:   Disclosure of system information, Disclosure of user information, Modification of user information, User access via network
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): 12.1 prior to 12.1-RU6-MP4
Description:   Several vulnerabilities were reported in Symantec Endpoint Protection. A remote user can conduct cross-site request forgery attacks. A remote authenticated user can gain elevated privileges. A remote user can inject SQL commands.

A remote user can include specially crafted code in the logging scripts that, when loaded by the target authenticated user, will take actions on the target interface acting as the target user [CVE-2015-8152].

The software does not properly validate user-supplied input. A remote user can supply a specially crafted parameter value to execute SQL commands on the underlying database and gain administrative privileges [CVE-2015-8153].

A previous security update to the sysplant driver (part of the Application and Device Control (ADC) component) did not properly validate user-supplied input. A remote authenticated user can bypass security controls to gain elevated privileges on the target system [CVE-2015-8154]. Systems that user ADC are affected.

Anatoly Katyushin of Kaspersky Labs reported the cross-site request forgery and SQL injection vulnerabilities.

Impact:   A remote user can take actions on the target system acting as the target authenticated user.

A remote authenticated user can gain elevated privileges on the target system.

A remote user can execute SQL commands on the underlying database.

Solution:   The vendor has issued a fix (12.1-RU6-MP4).

The vendor's advisory is available at:

https://www.symantec.com/security_response/securityupdates/detail.jsp?fid=security_advisory&pvid=security_advisory&year=&suid=20160317_00

Vendor URL:  www.symantec.com/security_response/securityupdates/detail.jsp?fid=security_advisory&pvid=security_advisory&year=&suid=20160317_00 (Links to External Site)
Cause:   Access control error, Input validation error
Underlying OS:  Windows (Any)

Message History:   None.


 Source Message Contents



[Original Message Not Available for Viewing]


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2019, SecurityGlobal.net LLC