SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Generic)  >   BIND Vendors:   ISC (Internet Software Consortium)
(Oracle Issues Fix for Oracle Linux) BIND Input Validation Flaw in Control Channel Lets Remote Users Cause the Target Service to Crash
SecurityTracker Alert ID:  1035316
SecurityTracker URL:  http://securitytracker.com/id/1035316
CVE Reference:   CVE-2016-1285   (Links to External Site)
Date:  Mar 17 2016
Impact:   Denial of service via network
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): 9.2.0 - 9.8.8, 9.9.0 - 9.9.8-P3, 9.9.3-S1 - 9.9.8-S5, 9.10.0 - 9.10.3-P3
Description:   A vulnerability was reported in BIND. A remote user can cause the target service to crash.

A remote user on a system specified in the 'named.conf' controls address list can send a specially crafted packet to the target rndc control channel to trigger a parsing error in 'sexpr.c' or 'alist.c' and cause denial of service conditions for clients.

Systems that accept remote commands on the control channel are affected.

Impact:   A remote user can cause denial of service conditions on the target service.
Solution:   Oracle has issued a fix.

The Oracle Linux advisory is available at:

http://linux.oracle.com/errata/ELSA-2016-0459.html

Vendor URL:  linux.oracle.com/errata/ELSA-2016-0459.html (Links to External Site)
Cause:   Input validation error
Underlying OS:  Linux (Oracle)
Underlying OS Comments:  5, 6, 7

Message History:   This archive entry is a follow-up to the message listed below.
Mar 10 2016 BIND Input Validation Flaw in Control Channel Lets Remote Users Cause the Target Service to Crash



 Source Message Contents

Subject:  [El-errata] ELSA-2016-0459 Important: Oracle Linux 7 bind security update

Oracle Linux Security Advisory ELSA-2016-0459

http://linux.oracle.com/errata/ELSA-2016-0459.html

The following updated rpms for Oracle Linux 7 have been uploaded to the 
Unbreakable Linux Network:

x86_64:
bind-9.9.4-29.el7_2.3.x86_64.rpm
bind-chroot-9.9.4-29.el7_2.3.x86_64.rpm
bind-devel-9.9.4-29.el7_2.3.i686.rpm
bind-devel-9.9.4-29.el7_2.3.x86_64.rpm
bind-libs-9.9.4-29.el7_2.3.i686.rpm
bind-libs-9.9.4-29.el7_2.3.x86_64.rpm
bind-libs-lite-9.9.4-29.el7_2.3.i686.rpm
bind-libs-lite-9.9.4-29.el7_2.3.x86_64.rpm
bind-license-9.9.4-29.el7_2.3.noarch.rpm
bind-lite-devel-9.9.4-29.el7_2.3.i686.rpm
bind-lite-devel-9.9.4-29.el7_2.3.x86_64.rpm
bind-pkcs11-9.9.4-29.el7_2.3.x86_64.rpm
bind-pkcs11-devel-9.9.4-29.el7_2.3.i686.rpm
bind-pkcs11-devel-9.9.4-29.el7_2.3.x86_64.rpm
bind-pkcs11-libs-9.9.4-29.el7_2.3.i686.rpm
bind-pkcs11-libs-9.9.4-29.el7_2.3.x86_64.rpm
bind-pkcs11-utils-9.9.4-29.el7_2.3.x86_64.rpm
bind-sdb-9.9.4-29.el7_2.3.x86_64.rpm
bind-sdb-chroot-9.9.4-29.el7_2.3.x86_64.rpm
bind-utils-9.9.4-29.el7_2.3.x86_64.rpm


SRPMS:
http://oss.oracle.com/ol7/SRPMS-updates/bind-9.9.4-29.el7_2.3.src.rpm



Description of changes:

[32:9.9.4-29.3]
- Fix CVE-2016-1285 and CVE-2016-1286


_______________________________________________
El-errata mailing list
El-errata@oss.oracle.com
https://oss.oracle.com/mailman/listinfo/el-errata
 
 


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2019, SecurityGlobal.net LLC