SecurityTracker.com
Keep Track of the Latest Vulnerabilities
with SecurityTracker!
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


Try our Premium Alert Service
 
Sign Up
Sign Up for Your FREE Weekly SecurityTracker E-mail Alert Summary
Instant Alerts
Buy our Premium Vulnerability Notification Service to receive customized, instant alerts
Affiliates
Put SecurityTracker Vulnerability Alerts on Your Web Site -- It's Free!
Partners
Become a Partner and License Our Database or Notification Service





Category:   Application (Generic)  >   Apache Struts Vendors:   Apache Software Foundation
Apache Struts Double OGNL Evaluation Lets Remote Users Execute Arbitrary Code on the Target System
SecurityTracker Alert ID:  1035271
SecurityTracker URL:  http://securitytracker.com/id/1035271
CVE Reference:   CVE-2016-0785   (Links to External Site)
Date:  Mar 15 2016
Impact:   Execution of arbitrary code via network, User access via network
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): 2.0.0 - 2.3.24.1
Description:   A vulnerability was reported in Apache Struts. A remote user can execute arbitrary code on the target system.

The software performs double OGNL evaluation of attribute values assigned to certain tags. A remote user can send specially crafted attribute data to execute arbitrary code on the target system. The code will run with the privileges of the target service.

Romain Gaucher of Coverity reported this vulnerability.

Impact:   A remote user can execute arbitrary code on the target system.
Solution:   The vendor has issued a fix (2.3.25).

The vendor's advisory is available at:

https://struts.apache.org/docs/s2-029.html

Vendor URL:  struts.apache.org/docs/s2-029.html (Links to External Site)
Cause:   State error
Underlying OS:  Linux (Any), UNIX (Any), Windows (Any)

Message History:   This archive entry has one or more follow-up message(s) listed below.
May 27 2016 (IBM Issues Fix for IBM Storwize) Apache Struts Double OGNL Evaluation Lets Remote Users Execute Arbitrary Code on the Target System
IBM has issued a fix for IBM Storwize V3500, V3700, V5000, and V7000.



 Source Message Contents



[Original Message Not Available for Viewing]


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2018, SecurityGlobal.net LLC