SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (E-mail Server)  >   Open-Xchange Vendors:   Open-Xchange Inc.
Open-Xchange Guard Access Control Flaw Lets Remote Authenticated Users Obtain Private Keys in Certain Cases
SecurityTracker Alert ID:  1035174
SecurityTracker URL:  http://securitytracker.com/id/1035174
CVE Reference:   CVE-2015-8542   (Links to External Site)
Date:  Mar 3 2016
Impact:   Disclosure of authentication information
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): 2.0, 2.2.0
Description:   A vulnerability was reported in Open-Xchange Guard. A remote authenticated user can obtain potentially sensitive information on the target system.

A remote authenticated user can issue a specially crafted 'getprivkeybyid' API call to obtain a PGP private key for a target user in certain cases.

If the target user provides a hashed value of a password in the 'auth' parameter for the same password as the target user's password and also provides the appropriate 'id' and 'cid' parameters (which are sequentially assigned), the system will allow download access to the target user's PGP private key.

The vendor was notified on December 10, 2015.

Impact:   A remote authenticated user can obtain a target user's PGP private keys in certain cases.
Solution:   The vendor has issued a fix (2.0.0-rev16, 2.2.0-rev8).
Vendor URL:  www.open-xchange.com/ (Links to External Site)
Cause:   Access control error
Underlying OS:  Linux (Any), UNIX (Any), Windows (Any)

Message History:   None.


 Source Message Contents



[Original Message Not Available for Viewing]


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2019, SecurityGlobal.net LLC