SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Generic)  >   Glibc Vendors:   GNU [multiple authors]
(Oracle Issues Fix for Oracle Linux) Glibc getaddrinfo() Stack Overflow Lets Remote or Local Users Execute Arbitrary Code
SecurityTracker Alert ID:  1035031
SecurityTracker URL:  http://securitytracker.com/id/1035031
CVE Reference:   CVE-2015-7547   (Links to External Site)
Date:  Feb 17 2016
Impact:   Execution of arbitrary code via local system, Execution of arbitrary code via network, User access via network
Fix Available:  Yes  Vendor Confirmed:  Yes  

Description:   A vulnerability was reported in Glibc. A remote or local user can execute arbitrary code on the target system.

A remote or local user can send specially crafted data to trigger a stack overflow in the getaddrinfo() function in the glibc DNS client resolver code ('resolv/nss_dns') and execute arbitrary code on the target system. The code will run with the privileges of the target application using the glibc library.

Various applications may be affected, including ssh, sudo, and curl.

Additional information is available at:

https://googleonlinesecurity.blogspot.com/2016/02/cve-2015-7547-glibc-getaddrinfo-stack.html


Impact:   A remote or local user can execute arbitrary code on the target system.
Solution:   Oracle has issued a fix.

The Oracle Linux advisory is available at:

http://linux.oracle.com/errata/ELSA-2016-0175.html

Vendor URL:  linux.oracle.com/errata/ELSA-2016-0175.html (Links to External Site)
Cause:   Boundary error
Underlying OS:  Linux (Oracle)
Underlying OS Comments:  6, 7

Message History:   This archive entry is a follow-up to the message listed below.
Feb 16 2016 Glibc getaddrinfo() Stack Overflow Lets Remote or Local Users Execute Arbitrary Code



 Source Message Contents

Subject:  [El-errata] ELSA-2016-0175 Critical: Oracle Linux 6 glibc security and bug fix update

Oracle Linux Security Advisory ELSA-2016-0175

http://linux.oracle.com/errata/ELSA-2016-0175.html

The following updated rpms for Oracle Linux 6 have been uploaded to the 
Unbreakable Linux Network:

i386:
glibc-2.12-1.166.el6_7.7.i686.rpm
glibc-common-2.12-1.166.el6_7.7.i686.rpm
glibc-devel-2.12-1.166.el6_7.7.i686.rpm
glibc-headers-2.12-1.166.el6_7.7.i686.rpm
glibc-static-2.12-1.166.el6_7.7.i686.rpm
glibc-utils-2.12-1.166.el6_7.7.i686.rpm
nscd-2.12-1.166.el6_7.7.i686.rpm

x86_64:
glibc-2.12-1.166.el6_7.7.i686.rpm
glibc-2.12-1.166.el6_7.7.x86_64.rpm
glibc-common-2.12-1.166.el6_7.7.x86_64.rpm
glibc-devel-2.12-1.166.el6_7.7.i686.rpm
glibc-devel-2.12-1.166.el6_7.7.x86_64.rpm
glibc-headers-2.12-1.166.el6_7.7.x86_64.rpm
glibc-static-2.12-1.166.el6_7.7.i686.rpm
glibc-static-2.12-1.166.el6_7.7.x86_64.rpm
glibc-utils-2.12-1.166.el6_7.7.x86_64.rpm
nscd-2.12-1.166.el6_7.7.x86_64.rpm


SRPMS:
http://oss.oracle.com/ol6/SRPMS-updates/glibc-2.12-1.166.el6_7.7.src.rpm



Description of changes:

[2.12-1.166.7]
- Update fix for CVE-2015-7547 (#1296028).

[2.12-1.166.6]
- Create helper threads with enough stack for POSIX AIO and timers 
(#1301625).

[2.12-1.166.5]
- Fix CVE-2015-7547: getaddrinfo() stack-based buffer overflow (#1296028).

[2.12-1.166.4]
- Support loading more libraries with static TLS (#1291270).


_______________________________________________
El-errata mailing list
El-errata@oss.oracle.com
https://oss.oracle.com/mailman/listinfo/el-errata
 
 


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2019, SecurityGlobal.net LLC