SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   OS (Linux)  >   Linux Kernel Vendors:   kernel.org
(Oracle Issues Fix for Oracle Linux) Linux Kernel UDP Processing Flaw Lets Remote Users Deny Service
SecurityTracker Alert ID:  1034755
SecurityTracker URL:  http://securitytracker.com/id/1034755
CVE Reference:   CVE-2015-5364, CVE-2015-5366   (Links to External Site)
Date:  Jan 21 2016
Impact:   Denial of service via network
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): Oracle Linux 5
Description:   Two vulnerabilities were reported in the Linux Kernel. A remote user can cause denial of service conditions on the target system.

A remote user can send a flood of UDP packets with specially crafted checksums to cause the target application to hang [CVE-2015-5364].

A remote user can send a flood of UDP packets with specially crafted checksums to cause the target application to stop reading packets [CVE-2015-5366].

Impact:   A remote user can cause the target application to hang.

A remote user can cause the target application to stop reading packets.

Solution:   Oracle has issued a fix.

The Oracle Linux advisory is available at:

http://linux.oracle.com/errata/ELSA-2016-0045.html

Vendor URL:  linux.oracle.com/errata/ELSA-2016-0045.html (Links to External Site)
Cause:   State error

Message History:   This archive entry is a follow-up to the message listed below.
Jul 7 2015 Linux Kernel UDP Processing Flaw Lets Remote Users Deny Service



 Source Message Contents

Subject:  [El-errata] ELSA-2016-0045 Important: Oracle Linux 5 kernel security update

Oracle Linux Security Advisory ELSA-2016-0045

http://linux.oracle.com/errata/ELSA-2016-0045.html

The following updated rpms for Oracle Linux 5 have been uploaded to the 
Unbreakable Linux Network:

i386:
kernel-2.6.18-408.el5.i686.rpm
kernel-PAE-2.6.18-408.el5.i686.rpm
kernel-PAE-devel-2.6.18-408.el5.i686.rpm
kernel-debug-2.6.18-408.el5.i686.rpm
kernel-debug-devel-2.6.18-408.el5.i686.rpm
kernel-devel-2.6.18-408.el5.i686.rpm
kernel-doc-2.6.18-408.el5.noarch.rpm
kernel-headers-2.6.18-408.el5.i386.rpm
kernel-xen-2.6.18-408.el5.i686.rpm
kernel-xen-devel-2.6.18-408.el5.i686.rpm

x86_64:
kernel-2.6.18-408.el5.x86_64.rpm
kernel-debug-2.6.18-408.el5.x86_64.rpm
kernel-debug-devel-2.6.18-408.el5.x86_64.rpm
kernel-devel-2.6.18-408.el5.x86_64.rpm
kernel-doc-2.6.18-408.el5.noarch.rpm
kernel-headers-2.6.18-408.el5.x86_64.rpm
kernel-xen-2.6.18-408.el5.x86_64.rpm
kernel-xen-devel-2.6.18-408.el5.x86_64.rpm

ia64:
kernel-2.6.18-408.el5.ia64.rpm
kernel-debug-2.6.18-408.el5.ia64.rpm
kernel-debug-devel-2.6.18-408.el5.ia64.rpm
kernel-devel-2.6.18-408.el5.ia64.rpm
kernel-doc-2.6.18-408.el5.noarch.rpm
kernel-headers-2.6.18-408.el5.ia64.rpm
kernel-xen-2.6.18-408.el5.ia64.rpm
kernel-xen-devel-2.6.18-408.el5.ia64.rpm


SRPMS:
http://oss.oracle.com/ol5/SRPMS-updates/kernel-2.6.18-408.el5.src.rpm

The following packages were rebuilt to be in sync with the updated 
kernel version (no changes other than updating the version number):

i386:
oracleasm-2.6.18-408.el5-2.0.5-1.el5.i686.rpm
oracleasm-2.6.18-408.el5PAE-2.0.5-1.el5.i686.rpm
oracleasm-2.6.18-408.el5xen-2.0.5-1.el5.i686.rpm
oracleasm-2.6.18-408.el5debug-2.0.5-1.el5.i686.rpm
ocfs2-2.6.18-408.el5-1.4.10-1.el5.i686.rpm
ocfs2-2.6.18-408.el5PAE-1.4.10-1.el5.i686.rpm
ocfs2-2.6.18-408.el5xen-1.4.10-1.el5.i686.rpm
ocfs2-2.6.18-408.el5debug-1.4.10-1.el5.i686.rpm

x86_64:
oracleasm-2.6.18-408.el5-2.0.5-1.el5.x86_64.rpm
oracleasm-2.6.18-408.el5xen-2.0.5-1.el5.x86_64.rpm
oracleasm-2.6.18-408.el5debug-2.0.5-1.el5.x86_64.rpm
ocfs2-2.6.18-408.el5-1.4.10-1.el5.x86_64.rpm
ocfs2-2.6.18-408.el5xen-1.4.10-1.el5.x86_64.rpm
ocfs2-2.6.18-408.el5debug-1.4.10-1.el5.x86_64.rpm

ia64:
oracleasm-2.6.18-408.el5-2.0.5-1.el5.ia64.rpm
oracleasm-2.6.18-408.el5xen-2.0.5-1.el5.ia64.rpm
oracleasm-2.6.18-408.el5debug-2.0.5-1.el5.ia64.rpm
ocfs2-2.6.18-408.el5-1.4.10-1.el5.ia64.rpm
ocfs2-2.6.18-408.el5xen-1.4.10-1.el5.ia64.rpm
ocfs2-2.6.18-408.el5debug-1.4.10-1.el5.ia64.rpm


SRPMS:
http://oss.oracle.com/el5/SRPMS-updates/oracleasm-2.6.18-408.el5-2.0.5-1.el5.src.rpm
http://oss.oracle.com/el5/SRPMS-updates/ocfs2-2.6.18-408.el5-1.4.10-1.el5.src.rpm


Description of changes:

kernel
[2.6.18-408.el5]
- [net] udp: fix behavior of wrong checksums (Denys Vlasenko) [1240757] 
{CVE-2015-5364 CVE-2015-5366}
- [net] ipv6/udp: Use correct var to determine non-blocking cond (Denys 
Vlasenko) [1240757] {CVE-2015-5364 CVE-2015-5366}
- [net] SNMP: Restore Udp6InErrors incrementation (Denys Vlasenko) 
[1240757] {CVE-2015-5364 CVE-2015-5366}


_______________________________________________
El-errata mailing list
El-errata@oss.oracle.com
https://oss.oracle.com/mailman/listinfo/el-errata
 
 


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2020, SecurityGlobal.net LLC