SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Database)  >   IBM DB2 Vendors:   IBM
IBM DB2 Lets Local Users Gain Elevated Privileges
SecurityTracker Alert ID:  1034562
SecurityTracker URL:  http://securitytracker.com/id/1034562
CVE Reference:   CVE-2015-1947   (Links to External Site)
Date:  Jan 4 2016
Impact:   Root access via local system
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): 9.7, 9.8, 10.1, 10.5
Description:   A vulnerability was reported in IBM DB2. A local user can obtain elevated privileges on the target system.

A local user can place a specially crafted library containing arbitrary code on the target system and then cause a setuid or setgid application to execute the arbitrary code with root privileges.

Impact:   A local user can obtain root privileges on the target system.
Solution:   IBM has issued a fix (10.5 FP7; APARs IT08751, IT08753, IT08754, IT08755).

The IBM advisory is available at:

https://www-304.ibm.com/support/docview.wss?uid=swg21970376

Vendor URL:  www-304.ibm.com/support/docview.wss?uid=swg21970376 (Links to External Site)
Cause:   Configuration error
Underlying OS:  Linux (Any), UNIX (AIX), UNIX (HP/UX), UNIX (Solaris - SunOS)

Message History:   None.


 Source Message Contents



[Original Message Not Available for Viewing]


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2020, SecurityGlobal.net LLC