SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Generic)  >   PHP Vendors:   PHP Group
PHP Class Name Format String Flaw Lets Remote Users Execute Arbitrary C ode
SecurityTracker Alert ID:  1034543
SecurityTracker URL:  http://securitytracker.com/id/1034543
CVE Reference:   CVE-2015-8617   (Links to External Site)
Date:  Dec 29 2015
Impact:   Execution of arbitrary code via network, User access via network
Fix Available:  Yes  Vendor Confirmed:  Yes  Exploit Included:  Yes  
Version(s): 7.0.0
Description:   A vulnerability was reported in PHP. A remote user can cause arbitrary code to be executed on the target system in certain cases.

A remote user can create a PHP file with a specially crafted class name that, when run on the target system, will trigger a format string error and execute arbitrary code on the target system.

The vendor was notified on December 12, 2015.

A demonstration exploit is available at:

https://www.exploit-db.com/exploits/39082/

Andrew Kramer reported this vulnerability.

Impact:   A remote user can create a PHP file that, when run on the target system, will execute arbitrary code on the target user's system.
Solution:   The vendor has issued a fix (7.0.1).
Vendor URL:  www.php.net/ (Links to External Site)
Cause:   Access control error
Underlying OS:  Linux (Any), UNIX (Any), Windows (Any)

Message History:   None.


 Source Message Contents



[Original Message Not Available for Viewing]


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2019, SecurityGlobal.net LLC