SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Generic)  >   Citrix Command Center Vendors:   Citrix
Citrix Command Center Input Validation Flaws in Web User Interface Java Servlets Let Remote Authenticated Users Inject SQL Commands
SecurityTracker Alert ID:  1034520
SecurityTracker URL:  http://securitytracker.com/id/1034520
CVE Reference:   CVE-2015-7999   (Links to External Site)
Date:  Dec 22 2015
Impact:   Disclosure of system information, Disclosure of user information, User access via network
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): 5.1 Build 35.4 and prior, 5.2 Build 43.19 and prior
Description:   A vulnerability was reported in Citrix Command Center. A remote authenticated user can inject SQL commands.

The Administration Web UI servlets do not properly validate user-supplied input. A remote authenticated user can supply a specially crafted parameter value to execute SQL commands on the underlying database.

This can be exploited to modify or delete system data.

Impact:   A remote authenticated user can execute SQL commands on the underlying database.
Solution:   The vendor has issued a fix (5.1 Build 36.7, 5.2 Build 44.11).

The vendor's advisory is available at:

http://support.citrix.com/article/CTX203787

Vendor URL:  support.citrix.com/article/CTX203787 (Links to External Site)
Cause:   Input validation error
Underlying OS:  Linux (CentOS), Linux (Red Hat Enterprise), Windows (2003), Windows (2008)

Message History:   None.


 Source Message Contents



[Original Message Not Available for Viewing]


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2021, SecurityGlobal.net LLC