SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Generic)  >   Apache CXF Vendors:   Apache Software Foundation
Apache CXF SAML SSO Module Lets Remote Users Conduct XML Wrapping Attacks to Bypass Authentication on the Target System
SecurityTracker Alert ID:  1034162
SecurityTracker URL:  http://securitytracker.com/id/1034162
CVE Reference:   CVE-2015-5253   (Links to External Site)
Date:  Nov 16 2015
Impact:   User access via network
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): prior to versions 2.7.18, 3.0.7, 3.1.3
Description:   A vulnerability was reported in Apache CXF. A remote user can bypass authentication.

A remote user can conduct an XML wrapping attack to bypass authentication on the target JAX-RS endpoint.

Systems using the SAML SSO module are affected.

Impact:   A remote user can bypass authentication on the target XML interface.
Solution:   The vendor has issued a fix (2.7.18, 3.0.7, 3.1.3).

The vendor's advisory is available at:

http://cxf.apache.org/security-advisories.data/CVE-2015-5253.txt.asc

Vendor URL:  cxf.apache.org/security-advisories.data/CVE-2015-5253.txt.asc (Links to External Site)
Cause:   Authentication error
Underlying OS:  Linux (Any), UNIX (Any), Windows (Any)

Message History:   This archive entry has one or more follow-up message(s) listed below.
Mar 1 2016 (Red Hat Issues Fix for JBoss Fuse) Apache CXF SAML SSO Module Lets Remote Users Conduct XML Wrapping Attacks to Bypass Authentication on the Target System
Red Hat has issued a fix for JBoss Fuse.



 Source Message Contents



[Original Message Not Available for Viewing]


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2019, SecurityGlobal.net LLC