SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Security)  >   XScreenSaver Vendors:   Zawinski, Jamie
XScreenSaver Hot-Swapping Bug Lets Local Users Bypass Security Restrictions
SecurityTracker Alert ID:  1034052
SecurityTracker URL:  http://securitytracker.com/id/1034052
CVE Reference:   CVE-2015-8025   (Links to External Site)
Date:  Nov 4 2015
Impact:   User access via local system
Fix Available:  Yes  Vendor Confirmed:  Yes  Exploit Included:  Yes  
Version(s): prior to 5.34
Description:   A vulnerability was reported in XScreenSaver. A physically local user can bypass security restrictions.

A physically local user can hot-swap monitors while the screen saver is locked to bypass screensaver password authentication and gain access to the target system.

The vulnerability resides in '/driver/subprocs.c'.

The original advisory is available at:

https://twitter.com/Thaolia/status/656823859304398848

James L. (@Thaolia) reported this vulnerability.

Impact:   A physically local user can bypass authentication on the target system.
Solution:   The vendor has issued a fix (5.34).

The vendor's advisory is available at:

https://www.jwz.org/blog/2015/10/xscreensaver-5-34/

Vendor URL:  www.jwz.org/xscreensaver/ (Links to External Site)
Cause:   State error
Underlying OS:  Linux (Any), UNIX (Any)

Message History:   This archive entry has one or more follow-up message(s) listed below.
Nov 4 2015 (Ubuntu Issues Fix) XScreenSaver Hot-Swapping Bug Lets Local Users Bypass Security Restrictions
Ubuntu has issued a fix for Ubuntu Linux 12.04 LTS.



 Source Message Contents



[Original Message Not Available for Viewing]


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2019, SecurityGlobal.net LLC