SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Generic)  >   UnZip Vendors:   Info-ZIP
(Ubuntu Issues Fix) UnZip Bugs Let Remote Users Deny Service and Execute Arbitrary Code
SecurityTracker Alert ID:  1034037
SecurityTracker URL:  http://securitytracker.com/id/1034037
CVE Reference:   CVE-2015-7696, CVE-2015-7697   (Links to External Site)
Updated:  Nov 9 2015
Original Entry Date:  Oct 30 2015
Impact:   Denial of service via network, Execution of arbitrary code via network, User access via network
Fix Available:  Yes  Vendor Confirmed:  Yes  Exploit Included:  Yes  

Description:   Two vulnerabilities were reported in UnZip. A remote user can cause arbitrary code to be executed on the target system. A remote user can cause the target service to crash.

A remote user can create a specially crafted password-protected archive that, when processed by the target user or application, will trigger a heap overflow and execute arbitrary code on the target system [CVE-2015-7696]. The code will run with the privileges of the target user or application.

A remote user can create a specially crafted archive file that, when loaded by the target user, will cause the unzip process to hang [CVE-2015-7697].

Gustavo Grieco reported these vulnerabilities.

Impact:   A remote user can create content that, when processed by the target user or application, will execute arbitrary code on the target system or cause the target unzip process to hang.
Solution:   Ubuntu has issued a fix.

[Editor's note: On November 9, 2015, Ubuntu issued a revised fix (USN-2788-2) to correct a non-security regression error in the original fix (USN-2788-1).]

The Ubuntu advisories are available at:

http://www.ubuntu.com/usn/usn-2788-1
http://www.ubuntu.com/usn/usn-2788-2

Vendor URL:  www.ubuntu.com/usn/usn-2788-2 (Links to External Site)
Cause:   Access control error, Boundary error
Underlying OS:  Linux (Ubuntu)
Underlying OS Comments:  12.04 LTS, 14.04 LTS, 14.10, 15.04

Message History:   This archive entry is a follow-up to the message listed below.
Oct 29 2015 UnZip Bugs Let Remote Users Deny Service and Execute Arbitrary Code



 Source Message Contents



[Original Message Not Available for Viewing]


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2021, SecurityGlobal.net LLC