SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Generic)  >   Xen Vendors:   Xen Project
Xen Populate-on-Demand Mode Memory Error Lets Local Users on a Guest System Cause Denial of Service Conditions on the Host System
SecurityTracker Alert ID:  1034034
SecurityTracker URL:  http://securitytracker.com/id/1034034
CVE Reference:   CVE-2015-7970   (Links to External Site)
Date:  Oct 30 2015
Impact:   Denial of service via network
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): 3.4 and later; 4.3.x, 4.4.x, 4.5.x, 4.6.x
Description:   A vulnerability was reported in Xen. A local user on the guest system can cause denial of service conditions on the host system.

A local user on the guest system can exploit a flaw in the Populate-on-Demand Mode and prevent use of a physical CPU for a significant period of time or trigger a watchdog timeout and subsequent reboot of the host system.

x86 HVM guest systems are affected.

x86 PV VMs are not affected.

ARM is not affected.

Andrew Cooper of Citrix reported this vulnerability.

Impact:   A local user on the guest system can cause denial of service conditions on the host system.
Solution:   The vendor has issued a fix (xsa150.patch).

The vendor's advisory is available at:

http://xenbits.xen.org/xsa/advisory-150.html

Vendor URL:  xenbits.xen.org/xsa/advisory-150.html (Links to External Site)
Cause:   Access control error
Underlying OS:  Linux (Any)

Message History:   None.


 Source Message Contents



[Original Message Not Available for Viewing]


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2020, SecurityGlobal.net LLC